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Preface

This preface introduces the AMBA Designer (ADR-301) User Guide. It contains the following 
sections:
• About this book on page x
• Feedback on page xiii.
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Preface 
About this book
This book is for AMBA Designer (ADR-301).

Product revision status

The rnpn identifier indicates the revision status of the product described in this book, where:
rn Identifies the major revision of the product.
pn Identifies the minor revision or modification status of the product.

Intended audience

This book is written for:

• system designers and system integrators using the AMBA Designer tool to either build a 
design with an AMBA infrastructure, or to configure AMBA components

• system verification engineers who want to verify the generated Register Transfer 
Language (RTL), for the AMBA components.

It is assumed that the intended audience is familiar with the RTL generation, synthesis, and 
verification processes of an ASIC design flow.

Using this book

This book is organized into the following chapters:

Chapter 1 Introduction 
Read this for a description of the AMBA Designer tool.

Chapter 2 Using AMBA Designer 
Read this for a description of how to start, configure preferences, create and add 
components, generate, simulate, synthesize component RTL, and operate in batch 
mode.

Chapter 3 Canvas Reference 
Read this for a description of the Canvas graphical user interface.

Appendix A Example RTL Design Flow 
Read this for a description of an example RTL design flow.

Appendix B Keyboard Shortcuts 
Read this for a description of keyboard shortcuts.

Appendix C Migration Guide 
Read this for a description of how to migrate components and systems from 
earlier versions of AMBA Designer.

Appendix D Revisions 
Read this for a description of the technical changes between released issues of this 
book.

 Glossary Read this for definitions of terms used in this book.
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. x
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Preface 
Typographical conventions

The typographical conventions are:

italic Highlights important notes, introduces special terminology, denotes 
internal cross-references, and citations.

bold Highlights interface elements, such as menu names. Denotes signal 
names. Also used for terms in descriptive lists, where appropriate.

monospace Denotes text that you can enter at the keyboard, such as commands, file 
and program names, and source code.

monospace Denotes a permitted abbreviation for a command or option. You can enter 
the underlined text instead of the full command or option name.

monospace italic Denotes arguments to monospace text where the argument is to be 
replaced by a specific value.

monospace bold Denotes language keywords when used outside example code.

 < and > Enclose replaceable terms for assembler syntax where they appear in code 
or code fragments. For example:
MRC p15, 0 <Rd>, <CRn>, <CRm>, <Opcode_2>

Additional reading

This section lists publications by ARM and by third parties.

See Infocenter, http://infocenter.arm.com, for access to ARM documentation.

ARM publications

This book contains information that is specific to this product. See the following documents for 
other relevant information:

• AMBA Designer (ADR-301) Installation Guide (ARM DUI 0456)

• AMBA AXI Protocol Specification (ARM IHI 0022)

• AMBA 3 APB Protocol Specification (ARM IHI 0024)

• AMBA 3 AHB-Lite Protocol Specification (ARM IHI 0033)

• AMBA Network Interconnect (NIC-301) Supplement to AMBA Designer (ADR-301) User 
Guide (ARM DSU 0003)

• PrimeCell® Interconnect (PL301) Supplement to AMBA Designer (FD001) User Guide 
(ARM DSU 0003A)

• AMBA Dynamic Memory Controller DMC-340 Supplement to AMBA Designer 
(ADR-301) User Guide (ARM DSU 0005)

• PrimeCell Static Memory Controller (PL350 series) Supplement to AMBA Designer 
(ADR-301) User Guide (ARM DSU 0006)

• PrimeCell DDR2 Dynamic Memory Controller (PL341) Supplement to AMBA Designer 
(ADR-301) User Guide (ARM DSU 0007)

• PrimeCell Generic Interrupt Controller (PL390) Supplement to AMBA Designer 
(ADR-301) User Guide (ARM DSU 0008)
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. xi
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Preface 
• AMBA DMA Controller DMA-330 Supplement to AMBA Designer (ADR-301) User 
Guide (ARM DSU 0009)

• PrimeCell Micro DMAC (PL230) Supplement to AMBA Designer (ADR-301) User Guide 
(ARM DSU 0010)

• PrimeCell AHB Bus Matrix (BP010) Supplement to AMBA Designer (ADR-301) User 
Guide (ARM DSU 0011)

• AMBA LPDDR2 Dynamic Memory Controller DMC-342 Supplement to AMBA Designer 
(ADR-301) User Guide (ARM DSU 0012)

• AMBA Level 2 Cache Controller (L2C-310) Supplement to AMBA Designer (ADR-301) 
User Guide (ARM DSU 0013)

• AMBA Design Kit Technical Reference Manual (ARM DDI 0243)

• AMBA Design Kit User Guide (ARM DUI 0183).
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. xii
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Preface 
Feedback
ARM welcomes feedback on this product and its documentation.

Feedback on this product

If you have any comments or suggestions about this product, contact your supplier and give:

• The product name.

• The product revision or version.

• An explanation with as much information as you can provide. Include symptoms and 
diagnostic procedures if appropriate.

Feedback on content

If you have comments on content then send an e-mail to errata@arm.com. Give:
• the title
• the number, ARM DUI 0333J
• the page numbers to which your comments apply
• a concise explanation of your comments.

ARM also welcomes general suggestions for additions and improvements.
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. xiii
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Chapter 1 
Introduction

This chapter introduces AMBA Designer. It contains the following sections:
• About AMBA Designer on page 1-2
• Features on page 1-4
• Resources on page 1-5
• Product revisions on page 1-7.
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 1-1
ID030610 Non-Confidential



Introduction 
1.1 About AMBA Designer
AMBA Designer tools enable you to:
• create systems based on AMBA interconnects and AMBA devices
• configure AMBA devices and generate RTL for the configurations you require
• stitch interconnects and components together
• generate top-level RTL for systems.

The AMBA Designer suite consists of:

Canvas Canvas is a graphical application that you can use to create new systems and 
modify existing ones. A system consists of leaf components or other subsystems. 
You can create and manipulate systems using a graphical representation that 
shows the components, their ports, and the connections between ports.

Configurators 
You can use configurators to configure AMBA components and generate RTL 
and test benches for these components.

 IP-XACT Component Library 
Components that you generate and save are stored in the Component Library.You 
can use these components and stitch them together with interconnects to generate 
top-level RTL modules for AMBA interconnect-based systems.

Figure 1-1 on page 1-3 shows the main AMBA Designer Canvas window. See Chapter 2 Using 
AMBA Designer for a description of the Configurator and IP-XACT Component Library panes 
within the Canvas window.
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 1-2
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Introduction 
Figure 1-1 AMBA Designer Canvas window

Note
 AMBA Designer only runs under UNIX environments.

See the AMBA Designer (ADR-301) Installation Guide for information about how to install 
AMBA Designer.
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 1-3
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Introduction 
1.2 Features
The AMBA Designer tools enable you to:

• Configure AMBA components with complex AMBA interconnects.

Note
 AMBA components can contain configurable IP, and comprise:

— configurable RTL source code
— a generator that translates user-defined sets of configuration parameters into any 

number of instances of the IP.

• Generate RTL and, where applicable, Out Of Box (OOB) testbenches for AMBA 
components. Components within the AMBA Designer Canvas are represented as 
IP-XACT components.

• Optimize the frequency for AMBA interconnects.

• Stitch together IP-XACT components to generate a top-level RTL module.

The tools generate configurations that are compatible across platforms, and can generate the 
RTL Verilog files and the associated testbenches for verifying the RTL.

For information about how to use the tools see:
• Chapter 2 Using AMBA Designer
• Chapter 3 Canvas Reference.
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 1-4
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Introduction 
1.3 Resources
AMBA Designer requires the following resources:
• A UNIX Operating System (OS), for example, Linux or Solaris.

Note
 The tools do not run on Microsoft Windows OSs.

• Licensed RTL for your choice of components and interconnects.
• Appropriate Electronic Design Automation (EDA) tools. See EDA tools.
• Perl.
• Tcl.
• Python.
• Open Verification Library (OVL).

See the AMBA Designer (ADR-301) Installation Guide for information about installation.

1.3.1 Third-party tools

This section describes third-party tools. It contains information about:
• EDA tools
• Third-party software on page 1-6.

EDA tools

This guide assumes that you have suitable EDA tools and compute resources. See the product 
Release note for a list of deliverables and any specific tool revisions required.

Table 1-1 shows the EDA tools that you can use.

Table 1-1 EDA tools

Purpose Vendor Tool Command line switch

RTL simulation Synopsys VCS vcs

Cadence NC-Verilog nc

Mentor Graphics ModelSim mti

Synthesis Synopsys Design Compiler
Physical Compiler

-

Logical Equivalence Checking (LEC) Synopsys Formality -

Cadence Conformal LEC -

Scripting ActiveState Perl -

Tcl -

Python -

Software development ARM RealView® Compilation Tools (RVCT) 
which provide armasm, armlink, fromelf

-

ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 1-5
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Introduction 
Note
 The AMBA Designer (ADR-301) Release Note:

• Lists specific tools and tool versions. ARM cannot guarantee that the deliverables are 
compatible with versions of the development tools other than those that the AMBA 
Designer (ADR-301) Release Note lists.

• Describes any special requirements that might affect the flow.

Third-party software

ARM acknowledges and thanks the respective owners for the Verilog Parser software that 
AMBA Designer uses:

/*
* Copyright (c) 1992, Bakul Shah <bvs@BitBlocks.com>
* All Rights Reserved.
*
* Permission to use, copy, modify, distribute or sell this software and
* its documentation for any purpose is hereby granted without fee, subject
* to the following conditions.
*
* 1. The above copyright, this list of conditions and the following
*    disclaimer must appear UNCHANGED in all copies of the software and
*    related documentation, and their derivative works or modified
*    versions
*
* 2. Binary distribution must be accompanied by documentation that
*    reproduces the above copyright, this list of conditions and the
*    following disclaimer.
*
* 3. Any modifications to the source code must be clearly marked as such.
*
* 4. The author's name may not be used to endorse or promote products
*    derived from this software without specific prior written permission.
*
* This software is provided by the author AS IS. The author DISCLAIMS
* any and all warranties of merchantability and fitness for a particular
* purpose. In NO event shall the author be LIABLE for any damages
* whatsoever arising in any way out of the use of this software.
*/
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 1-6
ID030610 Non-Confidential



Introduction 
1.4 Product revisions
This section describes the differences in functionality between product revisions of AMBA 
Designer:

r0p0-r2p0 Contains the following differences in functionality:
• Enables you to configure the following devices:

— DMC (PL340) r1p0
— SMC (PL350 series) r0p0.

• Updated to support version r1p0 of the High-Performance Matrix (PL301).
• Adds a PrimeCell Interconnect reconfiguration option that enables you to 

add or remove masters or slaves from a previously generated interconnect.

r2p0-r2p1 Contains the following differences in functionality:
• Links to Physical (L2P) functionality
• cascaded interconnect, configuration and RTL stitching
• Intellectual Property (IP) and architecture updates
• updated to support versions:

— r1p1 of the High-Performance Matrix (PL301)
— r2p0 of the DMC (PL340)
— r1p1 of the SMC (PL350).

• r2p1 SP1 Service Pack 1 contains the following changes:
• updated to support r1p2 and r2p0 of the SMC (PL350)
• SoC Designer 7 support.

Note
 All models and previous versions of AMBA Designer are 

incompatible with SoC Designer 7.

• An AMBA_Designer license feature is no longer taken when 
run in sdcanvas mode.

• Bandwidth Monitor Components (BMC)s are now 
optionally available when generating a PL301 model. 
These components collect read and write channel 
bandwidth and latency figures for model simulation.

• A global preferences environment variable enables you to 
define the location from where default user preferences are 
loaded. You can reset current user preferences to this 
global file.

• Option to save an AMBA Designer batch-mode 
configuration, .xml file, after generating the model view of 
a configured component, .mxp file.

Note
 When you have created Graphical User Interface (GUI) 

configurations, you can run AMBA Designer in batch 
mode, that is, without the GUI, so that you can create the 
RTL for, or simulate many designs in serial without 
requiring user interaction.
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 1-7
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Introduction 
• When you open a subsystem that AMBA Designer 
created, SoC Designer is stable.

• In batch mode operation, an error message is no longer 
issued when you exit SoC Designer.

r2p1-r2p2 Contains the following differences in functionality:
• enables you to configure the following devices:

— µDMAC (PL230) r0p0
— DMAC (PL330) r0p0
— DMC (PL340) Non-Volatile Memory (NVM) option r3p0
— DDR2 DMC (PL341) r0p0
— AHB Bus Matrix (BP010) r3p0

• enhanced L2P functionality, enabling you to configure AXI input and 
output constraints.

r2p2-r2p3 Contains the following differences in functionality:
• enables you to configure the GIC (PL390) r0p0
• improvements to installation scripts
• environment variable AD_HOME used for environment setup instead of 

MAXSIM_HOME

• moved preferences to a renamed $HOME/.ARM/AMBA_Designer_* directory 
hierarchy

• merged preferences into single preferences menu
• removed support for cycle-accurate modeling or Electronic System design 

Level (ESL) simulation
• no support for Microsoft Windows OS.

r2p3-r3p0 Contains the following differences in functionality:
• native support for IP-XACT components
• support of IP-XACT 1.4, including ad-hoc signals, tie-offs, and bit-slice 

connections
• support for configuring and stitching NIC-301r2 interconnects to other 

ARM IP
• all IP now has a one to one interface mapping with the RTL, that is, the 

same exact interfaces as the actual RTL
• support for hierarchical stitching, including support for external ports
• coloring of bus interface ports and connections based on the protocol.
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 1-8
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Chapter 2 
Using AMBA Designer

This chapter describes how to run AMBA Designer, configure preferences, and operate in batch 
mode. It contains the following sections:
• About the AMBA Designer flow on page 2-2
• Using the Graphical User Interface (GUI) on page 2-4
• Batch mode operation on page 2-20.
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 2-1
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Using AMBA Designer 
2.1 About the AMBA Designer flow
This section describes the general flow for the creation of systems. Peripherals and 
interconnects in SoC systems are highly configurable. To speed up the flow, consider the 
component and interconnect configurations that you might require before you use the tools.

To create a system with the tools:

1. Start AMBA Designer. See:
• How to start a session on page 2-4.

2. Setup preferences. See:
• How to set preferences on page 2-4
• AMBA Designer Preferences dialog on page 3-50.

3. Create new configurations of components, and generate components. See:
• How to create and configure components on page 2-6
• Using components on page 3-31.

4. Add the generated components to the Component Library. See:
• How to generate RTL for a component on page 2-9
• Appendix A Example RTL Design Flow.

5. Add components to the design. See:
• How to create and configure components on page 2-6
• Using components on page 3-31.

6. Connect components. See:
• How to add connections on page 2-15
• Making connections between components on page 3-36.

7. Stitch components. See:
• How to stitch components on page 2-17
• IP-XACT stitching on page 3-44.

You can use the Canvas interface to open third-party EDA tools to simulate the generated RTL, 
synthesize the design, and run other EDA tools such as equivalence checkers.

You can run the tools:
• from the GUI
• in batch mode using the command line.

Figure 2-1 on page 2-3 shows a typical design flow.
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Figure 2-1 Design flow

For information about how to:
• run the tools from the GUI, see Using the Graphical User Interface (GUI) on page 2-4
• use batch mode, see Batch mode operation on page 2-20
• install the tools, see the AMBA Designer (ADR-301) Installation Guide
• use the Canvas, see Chapter 3 Canvas Reference.
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2.2 Using the Graphical User Interface (GUI)
This section describes how to create a design using the GUI.

Note
 Commands are available by using the menu bar and the context sensitive pop-up menus. To see 
a context-sensitive menu, right-click items in the GUI.

This section contains the following subsections:
• How to start a session
• How to set preferences
• How to create and configure components on page 2-6
• How to generate RTL for a component on page 2-9
• RTL Simulation and Synthesis on page 2-10
• Synthesis on page 2-12
• How to add components to the Component Library on page 2-13
• How to add configured components to the design on page 2-14
• How to add connections on page 2-15
• How to stitch components on page 2-17.

2.2.1 How to start a session

To start AMBA Designer from a console, type:

adcanvas <filename>

See Table 2-1 on page 2-21 for a list of command line options. If you do not specify an option 
argument then Canvas opens with a blank Diagram Window.

Note
 You must set up the environment before you can run AMBA Designer. The command you use 
depends if your operating system shell is either:
Bourne Enter  source <AMBA Designer install directory>/etc/setup.sh
C-Shell Enter  source <AMBA Designer install directory>/etc/setup.csh

Where <AMBA Designer install directory> is the AMBA Designer installation directory.

2.2.2 How to set preferences

You can configure:
• General preferences for:

— appearance
— Component Library.

• Canvas preferences for:
— appearance
— the Diagram Window
— IP-XACT.

To set preferences:

1. Select File → Preferences.... See Figure 2-2 on page 2-5.
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Figure 2-2 Preferences... selection

This opens the AMBA Designer Preferences dialog box. See Figure 2-3.

2. To change settings:
a. Click an item in the left-hand pane in the AMBA Designer Preferences dialog box.

Note
 You can expand and collapse the branches of the hierarchy to show or hide items. 

To expand or collapse the view, click the triangle symbol to the left of the text label 
in the hierarchy.

Figure 2-3 AMBA Designer Preferences dialog box

b. Change the appropriate items in the right-hand pane.

3. Click OK to confirm your changes.
Click OK & Save to confirm and save your changes.
Click Cancel to cancel your changes.
Click Help for help with the dialog box.

The hierarchy enables you to change settings for:

General The General area contains settings for General preferences, the Home Directory 
for your work, your choice of Text Editor, Browser, and Design Preferences.
See General preferences on page 3-50.
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General Appearance 
The General Appearance area contains settings for Tool Bar Options, Magnify 
Object Delay, and Fonts.
See General Appearance preferences on page 3-54.

General Component Library 
The Component Library area contains settings for the Working Directory and 
Additional Component Configuration Files.
See General Component Library preferences on page 3-55.

Canvas The Canvas area contains settings for Application Options and Save Options.
See Canvas preferences on page 3-56.

Canvas Appearance 
The Canvas Appearance area contains settings for the Hierarchy tab and the 
Component Window.
See Canvas Appearance preferences on page 3-58.

Canvas Diagram 
The Canvas Diagram area contains settings for Double Click on Objects, Grid 
Options, and Miscellaneous.
See Diagram Window preferences on page 3-58.

Canvas IP-XACT 
The Canvas IP-XACT area contains settings for IP-XACT Global Preference, 
IP-XACT Default Values, IP-XACT Repository, and IP-XACT Files.
See Canvas IP-XACT preferences on page 3-60.

See AMBA Designer Preferences dialog on page 3-50 for more information.

2.2.3 How to create and configure components

You must create specific component configurations to use in your design.

Note
 AMBA Designer must contain registered forms of components. The AMBA installation 
package provides a UNIX script that enables you to register AMBA components with AMBA 
Designer. See the AMBA <Component> Release Note for information about how to use the 
script.

To create and configure a new component:

1. Make sure that Canvas shows the AMBA Configuration Window, and Configurators tab. 
See Figure 2-4 on page 2-7.
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Figure 2-4 AMBA Configuration Window

2. Double-click the name of your chosen component in the AMBA Configuration Window.
A component Configurator Window appears. Figure 2-5 shows an example of a 
Configurator Window.

Figure 2-5 Example Configurator Window

3. Fill in the necessary configuration details in the Configurator Window.
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Note
 Components might have more than one configuration tab or pane in the Configurator 

Window. Complete each as necessary by selecting the appropriate tabs and buttons to 
configure all the options.

To complete the configuration, click OK. A new tab appears in the Diagram Window with 
the new component part displayed. See Figure 2-6.
To cancel configuration without creating the component, click Cancel.

Figure 2-6 Example new component

4. To save the component, either:
• click Save on the main toolbar
• select File → Save on the main menu.
Your component is saved in your work space.

For specific configuration details for your chosen component, see the appropriate AMBA 
<Component> supplement to the AMBA Designer User Guide.

Note
 To add a component to the Component Library and use it in your design, you must first generate 
the component RTL and then add it to the library. See:
• How to generate RTL for a component on page 2-9
• How to add components to the Component Library on page 2-13.

See Using components on page 3-31 for information about how to use components.
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2.2.4 How to generate RTL for a component

To generate RTL for a component:

1. Right-click the component to display the context-sensitive menu.
Figure 2-7 shows the component context-sensitive menu.

Figure 2-7 Example component generation

2. Select Design → <component_name> RTL Design Flow Manager... from the 
context-sensitive menu.
The RTL Design Flow Manager dialog box opens. See Figure 2-8.

Figure 2-8 Example RTL Design Flow Manager dialog box

3. Click Generate RTL to generate the component.
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The Commands pane of the RTL Design Flow Manager shows a progress bar in black. 
When the Generate RTL process has completed, the progress bar changes color to one of 
the following:
Green To indicate that AMBA Designer simulated the RTL successfully.

Note
 If you want to simulate and synthesize the generated component RTL in the 

current RTL Design Flow Manager session, leave the dialog box open.

Red To indicate that AMBA Designer failed to generate the RTL.
Click Details to open the Output Window pane to display information about 
the status of the process.

4. To end the current RTL Design Flow Manager session, click Close.

5. To save the component, either:
• click Save on the main toolbar
• select File → Save on the main menu.
Your component is saved in your workspace.

Note
 You must run a separate instance of the Generate RTL process for each component you require 
RTL. However, before generating additional components, you must add the generated 
component to the Component Library. See How to add components to the Component Library 
on page 2-13.

For information about how to use components, see Using components on page 3-31.

2.2.5 RTL Simulation and Synthesis

This section describes how to run RTL simulation and synthesis tools from the Canvas interface.

Note
 You can only start the Simulate process when the Generate RTL process has completed 
successfully in the current RTL Design Flow Manager session.

Before you run the simulation, you must verify that the simulation preferences are appropriately 
configured. The following sections describe the simulation stage:
• RTL simulation preferences
• OVL assertions flag on page 2-11
• Simulate on page 2-11.

See EDA tools on page 1-5 for information about the third-party EDA tools that you can use.

RTL simulation preferences

You must set the AMBA Designer simulation preferences for your chosen simulator.

To configure the simulation preferences:

1. Click Preferences in the RTL Design Flow Manager dialog box to open the RTL Design 
Flow Manager Preferences dialog box. See Figure 2-9 on page 2-11.
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Figure 2-9 RTL Design Flow Manager Preferences dialog box

2. Select the simulator that corresponds to the simulation tool for your device.

OVL assertions flag

If the AMBA device supports Open Verification Library (OVL) assertions then you can, if 
required, simulate using OVL assertions.

For information about how to install OVL, see the AMBA Designer (ADR-301) Installation 
Guide.

Note
 It is not necessary to install or enable OVL assertions to simulate any of the examples supplied 
with the tools.

To enable OVL assertions:

1. Select the Use OVL Assertions check box in the Flags pane of the RTL Design Flow 
Manager Preferences dialog box to enable simulation with OVL assertions.

2. Click OK to save the preferences and close the dialog box.

Simulate

To simulate the RTL:

1. Click Simulate in the RTL Design Flow Manager dialog box. See Figure 2-10.

Figure 2-10 Simulate RTL

The simulate RTL process starts. The progress bar in the Commands pane of the RTL 
Design Flow Manager dialog box displays the progress.
On completion of the simulate RTL process, the progress bar changes color to one of the 
following:
Green To indicate that AMBA Designer simulated the RTL successfully.
Red To indicate that AMBA Designer failed to simulate the RTL.
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 2-11
ID030610 Non-Confidential



Using AMBA Designer 
Click Details to open the Output Window pane to display information about 
the status of the process.

Note
 If you want to also synthesize the generated component RTL in the current RTL Design 

Flow Manager session, leave the dialog box open.

2. Click Close to close the RTL Design Flow Manager dialog box.

2.2.6 Synthesis

For information about the third-party EDA tools you can use, see EDA tools on page 1-5.

Note
 • You can only start the Synthesize process when the Generate RTL process has completed 

successfully in the current RTL Design Flow Manager session.

• You must configure your device with the appropriate location for your chosen EDA 
synthesis tool.

• To synthesize the example created, you must install the appropriate ARM Physical IP 
libraries.

To synthesize the RTL:

1. Click Preferences in the RTL Design Flow Manager dialog box to open the RTL Design 
Flow Manager Preferences dialog box. See Figure 2-11.

Figure 2-11 RTL Design Flow Manager Preferences dialog box

2. To perform Logical Equivalence Checking (LEC) during synthesis, select the Run LEC 
check box in the Flags pane.

Note
 You must configure your device with the appropriate location for your chosen LEC tool.

3. Click OK to save the preferences.

4. Close the RTL Design Flow Manager Preferences dialog box.

5. Click Synthesize in the RTL Design Flow Manager dialog box. See Figure 2-12 on 
page 2-13.
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Figure 2-12 Synthesize RTL

The Synthesize process starts. The progress bar in the Commands pane of the RTL Design 
Flow Manager dialog box displays the progress.
On completion of the synthesize RTL process, the progress bar changes color to one of 
the following:
Green To indicate that AMBA Designer synthesized the RTL successfully.
Red To indicate that AMBA Designer failed to synthesize the RTL.

Click Details to open the Output Window pane to display information about 
the status of the process.

6. Click Exit to close the RTL Design Flow Manager dialog box.

2.2.7 How to add components to the Component Library

This section describes how to add a generated component to the Component Library.

Note
 Before you can add the component to the library, you must generate the component RTL. See 
How to generate RTL for a component on page 2-9.

To add a component to the Component Library:

1. Right-click the component to display the context-sensitive menu.
Figure 2-13 on page 2-14 shows the component context-sensitive menu.
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Figure 2-13 Example addition of component to library

2. Select Design → Add <component_name> to Component Library... from the 
context-sensitive menu.
Dialogs appear that show the status of the process. The dialogs disappear with no error 
messages and the component appears in the Component Window on successful 
completion.

For information about how to use components, see Using components on page 3-31.

2.2.8 How to add configured components to the design

To add a component to a system, either:

• Choose a component in the Component Window and drag it into the Diagram Window.

• Use the Diagram Window context-sensitive menu as follows:
1. Right-click the Diagram Window to open the context-sensitive menu.
2. Select Add Component... from the list to open the Select Component dialog box. 

See Figure 2-14 on page 2-15.
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Figure 2-14 Select Component dialog box

3. Choose a component from the list. You can type a name for the component in the 
Instance Name (Optional): field.

4. Click OK and then position the component in the Diagram Window.

• Select Insert → Add Component... on the main menu and use the Select Component 
dialog box to add your chosen component.

2.2.9 How to add connections

To add connections between components, either:
• click Connect on the main toolbar
• select Insert → Add Connection... on the main menu to display the Create IP-XACT 

Connection dialog box.

To add connections using the main toolbar:

1. Click Connect.

2. Click the start port and then click the end port for each connection.
If you connect the wrong ports together, immediately select Edit → Undo in the main 
menu to remove the connection.
Figure 2-15 on page 2-16 shows the port connections for this system.
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Figure 2-15 Connected system

3. Select File → Save As... from the main menu to open the Save As... dialog box.

4. Enter a name in the Project Name field of the Save As... dialog box. See Figure 2-16.

Figure 2-16 Save As... dialog box

5. Click OK to close the Save As... dialog box.

Note
 The canvas also supports ad-hoc connections and port tie-offs for IP-XACT 1.4 components. 
See Making connections between components on page 3-36 for more information.
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2.2.10 How to stitch components

To stitch the IP of a number of components together to create a system, perform the following 
steps:

Note
 You can only stitch one component system at a time.

1. Create external ports for all connections that are to be brought up to the top-level during 
stitching.
To create an external port, right-click on a component port and select Create External 
Port from the popup menu. See Figure 2-17.

Figure 2-17 Create an External Port

An appropriately named external port connector and connecting wire are automatically 
connected to the component port. See Figure 2-18.

Figure 2-18 External Port connection

To complete the action, drag the external connector to the position you require and 
left-click. To cancel the action, press Esc any time before left-clicking.

Note
 If you want to bring all the unconnected signal ports in the system up to the top-level, 

select Export all unconnected in the AMBA Designer - RTL Design Flow Manager 
Preferences dialog box. See IP-XACT_Stitching tab on page 3-44.

2. Save your design.

3. On the main menu, select Design → IP-XACT RTL Stitching.... See Figure 2-19.

Figure 2-19 IP-XACT RTL Stitching menu item

AMBA Designer displays the AMBA Designer - RTL Design Flow Manager dialog box. 
See Figure 2-20 on page 2-18.
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Figure 2-20 IP-XACT RTL Stitching process

4. Click Preferences to open the RTL Design Flow Manager Preferences dialog box. See 
Figure 2-21.

Figure 2-21 RTL Design Flow Manager Preferences dialog - IP-XACT_Stitching tab

Either accept the default IP-XACT stitching preferences or make the necessary changes 
using this dialog box. See IP-XACT_Stitching tab on page 3-44 for more information 
about the flags and options.
To close the RTL Design Flow Manager Preferences dialog box and save your 
preferences, click OK. To close the dialog box without changing preferences click 
Cancel.

5. In the AMBA Designer RTL Design Flow Manager dialog box, click Stitch RTL to start 
the process.

Note
 If you close the dialog box during RTL stitching by using the Abort or X buttons, the 

system being stitched, if present, is removed from the Component Library. If the system 
is not present, no action is taken.

The AMBA Designer - RTL Design Flow Manager dialog box contains the following 
information:
• the path name to the design file
• a progress bar that indicates:

— progress, with a moving black bar
— successful completion, with a solid green bar
— unsuccessful completion, with a solid red bar.
To see more information, click Details.

6. Click Close to close the AMBA Designer - RTL Design Flow Manager dialog box.
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Note
 If the Auto Add Stitched System to Component Library flag is selected in the 

IP-XACT_Stitching tab, then when you close the dialog box, the system is automatically 
added to the Component Library. Otherwise, no action is taken.

The IP stitching feature generates reports in the following directory during the stitching process:

/home/<user>/.ARM/AMBA_Designer/<x>.<y>/Designs/

Where <x> is the major revision number and <y> is the minor revision number of AMBA 
Designer, for example, 3.0.

The reports depend on the components that you include in your design.

See IP-XACT stitching on page 3-44 for more information.
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2.3 Batch mode operation
AMBA Designer supports batch mode operation so that you can start regression tests without 
using the GUI.

When you initially invoke the RTL generation process of the RTL Design Flow Manager, it 
creates an XML configuration file for the configured AMBA component. The RTL generation 
process then creates the RTL based on the information that the XML file contains. AMBA 
Designer creates the XML file in a directory under the Designs directory. See Figure 2-22.

Figure 2-22 Location of XML file

In Figure 2-22, <x> represents the major revision number and <y> represents the minor revision 
number of AMBA Designer, for example, 3.0.

During batch mode, AMBA Designer uses the XML configuration file to perform any of the 
following functions:
• Generate RTL
• Generate RTL and simulate
• Generate RTL and synthesize
• Generate RTL, simulate, and synthesize.

You can choose:
• the simulator that AMBA Designer uses
• whether or not to enable OVL assertions
• whether or not to use LEC.

See Batch mode usage and commands on page 2-21 for a description of batch mode commands.

2.3.1 Saving a batch mode configuration file

Batch mode requires a batch mode configuration file. For each generated component for a 
configuration, AMBA Designer can save a configuration file for batch mode in XML format.

To generate a configuration file for batch mode:

1. Configure the IP using the Configurator Window. See How to create and configure 
components on page 2-6.

2. Select Save AMBA Designer Batch Mode XML Configuration File from the 
context-sensitive menu of the component.

Note
 This option is only available if the AMBA Designer license feature is present.

AMBA_Designer/

home/
<user>/

.ARM/

Designs/
<product_configuration>_RTL/

<top-level directory>/

<x>.<y>/
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2.3.2 Batch mode usage and commands

The AMBA Designer batch mode command -b covers all supported IP. The syntax is:

adcanvas -b <filename> [options]

Table 2-1 lists the available command line options.

Table 2-1 Command line options

Option Example usage Description

--background color adcanvas --background 8000 Set the default background color and an application 
palette. Light and dark shades are calculated based on 
the new palette.

--button color adcanvas --button 8000 Set the default button color.

--cmap adcanvas --cmap Install a private color map on an 8-bit display.

--display display_option adcanvas --display $DISPLAY Set the X display. The default is $DISPLAY.

--font new_font adcanvas --font arial Set the application font.

--foreground color adcanvas --foreground 8000 Set the default foreground color.

--geometry new_geometry adcanvas --geometry new_geometry Set the client geometry of the main window.

--maxlib component library adcanvas --maxlib mymaxlib.conf Start Canvas with the specified library file loaded.

--ncols count adcanvas --ncols 216 Limit the number of colors allocated in the color cube 
on an 8-bit display. If the count is 216, a 6×6×6 color 
cube is used, that is, six levels of red, blue, and green. 
For other values, the system uses a cube approximately 
proportional to a 2×3×1.

--visual Truecolor adcanvas --visual Truecolor Force the application to use TrueColor on an 8-bit 
display.

-b adcanvas -b -product <filename> [options] Start Canvas in batch mode.
product is the product code for an AMBA component. 
See the AMBA Designer (ADR-301) Release Note for 
the list of product codes.

-gen, -generate adcanvas -b -product <filename> [-gen] Generate RTL only.

-sim, -simulate adcanvas -b -product <filename> [-sim] Generate RTL and simulate.

-syn, -synth, -synthesise adcanvas -b -product <filename> [-syn] Generate RTL and synthesize.

-all adcanvas -b -product <filename> [-all] Generate RTL, simulate, and synthesize. This is the 
default behavior.

-ovl, -noovl adcanvas -b -product <filename> [-ovl] Enable or disable OVL assertions during simulation.
The default is to use predefined preferences.

-lec, -nolec adcanvas -b -product <filename> [-lec] Enable or disable LEC of synthesized netlist against 
RTL.
The default is to use predefined preferences.

simulator adcanvas -b -product <filename> [options] Select simulator.
See Table 1-1 on page 1-5 for the simulator options.
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-n, --nomaxlib adcanvas --nomaxlib

adcanvas –n

Start Canvas without loading any components.

-v or --version adcanvas --version Print the version of the tool without starting it.

<filename> adcanvas mySystem.adg Start Canvas with the specified file open. The 
specified file must be a *.adg file.

-h, --help adcanvas --help Print the usage information.

Table 2-1 Command line options (continued)

Option Example usage Description
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Canvas Reference

This chapter provides a reference for AMBA Designer Canvas. It contains the following sections:
• About Canvas on page 3-2
• Canvas application window on page 3-6
• Using components on page 3-31
• IP-XACT stitching on page 3-44
• AMBA Designer Preferences dialog on page 3-50
• Label Properties dialog on page 3-63
• Create IP-XACT Connection dialog on page 3-65
• Edit Parameters dialog on page 3-66.
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3.1 About Canvas
AMBA Designer Canvas is a graphical application that you can use to create new systems and 
load and modify existing systems.

A system can consist of connected components and previously created systems. You create and 
edit systems using the Canvas interface. This interface shows the components, ports, and 
connections between the ports. You can add external ports for a system, and add labels to 
annotate the diagram. Figure 3-1 shows the main Canvas window.

Figure 3-1 Combined Canvas window

Typically, to create a system:

1. Drag components from the Component Window to the Diagram Window. You can also 
right-click a space in the Diagram Window and select Add Component from the 
context-sensitive menu. See:
• Component Window on page 3-19
• Using components on page 3-31.
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2. Connect the components ports together. See:
• Making connections between components on page 3-36
• Using components on page 3-31.

3. Optionally, improve the appearance of the design by moving the component position, 
rerouting the connections, or adding informative labels. See:
• Making connections between components on page 3-36
• Using components on page 3-31.

3.1.1 Window layout

Table 3-1 shows the main parts of the GUI.

Note
 You can select the windows that appear. Not all windows appear in the default view. See Window 
menu on page 3-13.

The Component Window, AMBA Configuration Window, and Parameter Window comprise the 
Tools Window. See Figure 3-1 on page 3-2.

Note
 You can undock the Tools Window from the main Canvas window.

The Output Window displays system console output and system check information. See 
Figure 3-1 on page 3-2. If required, you can undock the Output Window from the main Canvas 
window, to make more efficient use of your console space.

Table 3-1 User interface elements

Element Description

Main menu The main menu presents commands with their corresponding keyboard shortcuts.

Toolbar The toolbar contains buttons for frequently-used features.

Component Window This window contains a list of all the components available for use in your system.

AMBA Configuration Window This window contains tabs for AMBA component configurators and the design hierarchy of the 
components and external ports in the current system.

Parameter Window This window contains all the parameters of the selected component.

Note
 This applies only to legacy components. This window does not display IP-XACT component 
parameters.

Diagram Window This window contains a graphical representation of the system.

Output Window This window appears below the Diagram Window and displays system console output and system 
check information.

Status Bar The status bar displays information about menu items, commands, buttons, and components.

Master Output Window This window shows the complete system console output and system check information from the 
start of a session.
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Figure 3-2 shows a Diagram Window with an example system.

Figure 3-2 Diagram Window with an example system

When you open the Canvas tool, the Diagram Window, Component Window, and AMBA 
Configuration Window from the Tools Window appear together by default.

Figure 3-3 on page 3-5 shows the Master Output Window with an example of startup 
information from the console. You access the Master Output Window from the main menu by 
selecting Window → Master Output Window.
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Figure 3-3 Master Output Window
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3.2 Canvas application window
This section describes the windows and controls on the application window. It contains the 
following subsections:
• System menu and controls
• Projects tab
• Title bar
• Main menu and toolbar
• Status bar on page 3-15
• Diagram Window on page 3-15
• Output Window on page 3-19
• Component Window on page 3-19
• AMBA Configuration Window on page 3-26
• Parameter Window on page 3-28.

3.2.1 System menu and controls

Canvas supports the following standard system menu and controls:
• move
• size
• minimize
• maximize
• restore
• close.

The appearance and function depends on the operating system. See the operating system help 
for more information about how these work.

3.2.2 Projects tab

The tabs below the Diagram Window list the projects that are currently loaded. If only one 
project is open, only one tab is displayed. Clicking on a tab displays the Diagram Window and 
Tools Window for that project.

3.2.3 Title bar

The title bar of the application window contains the name of the application, the name of the 
current system being edited, and the state of the project. If you modified the system and did not 
yet save it, an asterisk is displayed to the right of the system name.

3.2.4 Main menu and toolbar

This section describes the main menu and toolbar. It contains the following sections:
• Toolbar on page 3-7
• File menu on page 3-7
• Edit menu on page 3-8
• View menu on page 3-9
• Insert menu on page 3-10
• Object menu on page 3-11
• Design menu on page 3-12
• Tools menu on page 3-12
• Window menu on page 3-13
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• Help menu on page 3-14.

Figure 3-4 shows the main menu and toolbar.

Figure 3-4 Menu and toolbar

Toolbar

You can use the toolbar buttons for frequent operations instead of using the main menu. The 
toolbar contains the following button groups:

New, Open, Save Use these buttons to create, open, or save projects.
See File menu.

Cut, Copy, Paste, Del 
Use these buttons to cut, copy, paste, or delete components.
See Edit menu on page 3-8.

Undo, Redo Click Undo to cancel the last change you made in the Diagram Window. 
Click Redo to cancel the last Undo.
See Edit menu on page 3-8.

Edit, Connect Use these buttons to change the mode for the Diagram Window.
In edit mode, you can use the cursor to select and move components.
In connect mode, you can use the cursor to connect the ports of 
components together.

Comp, Port, Label, Connection 
Use these buttons to specify the type of object that you are adding to the 
Diagram Window.

Signal, Bus Use these buttons to hide or display the specified ports and connections in 
the Diagram Window.

Grid Click Grid to display or hide the grid in the Diagram Window.

In, Out, 100% Use these buttons to change the zoom level in the Diagram Window.

Zoom % AMBA Designer contains a Zoom % Toolbar that displays the current 
zoom level and has a spin control that you can use to increase or decrease 
the zoom level. The Zoom % Toolbar is displayed by default to the right 
of the main toolbar. You can also select Zoom Toolbar from the Windows 
menu. If the toolbar is not displayed, you can also change the zoom level 
by selecting Zoom In or Zoom Out from the context-sensitive menu of 
the Diagram Window.

File menu

New You can create a new system at any time. If you have already loaded systems, they 
remain loaded. To redisplay them, select the system from the appropriate project 
tab.
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Open… You can open a previously saved system at any time. If you have already loaded 
systems, they remain loaded. To redisplay them, select the system from the 
appropriate project tab.

Close You can close the system at any time. If you have modified the system and not 
saved it, Canvas prompts you to save the current system.

Save You can save the current system at any time. After you save a modified system, 
the title bar no longer shows an asterisk.

Save As… You can save the current system under a new name at any time. When you use the 
standard file Save As dialog box, Canvas prompts you to enter the name of the 
new system. After you change the system name, the title bar is updated to reflect 
the new name and saved status.

Note
 You can save read-only files under a new name and then load and modify the 

newly-named system.

Print… You can print the contents of the Diagram Window. Use the Print dialog box to 
select your printer configuration.

Preferences… 
The Preferences dialog box enables you to configure and customize all the 
AMBA Designer features.
See AMBA Designer Preferences dialog on page 3-50.

File list Canvas displays a list of the recently opened *.adg project files near the bottom 
of the file menu. Select a file to reopen the project.

Exit Exit Canvas. If you have modified the system and not saved it, AMBA Designer 
prompts you to save the current system. If you click Cancel, Canvas remains 
open and does not delete the modified system.

Edit menu

Undo, Redo Canvas supports the standard undo and redo editing features. The menu item 
shows what type of undo or redo is available. For example, if you cut a 
component out of the diagram, the undo menu item shows Undo – Cut 
Component. There are no limits to the number of undo or redo actions other than 
the operating system limitations.

Note
 Undo and Redo do not support:

• external port creation, deletion, or connection
• Hide Port, Unhide Port, or Disable Port options
• changes made to user preferences.

Cut, Copy, Paste, Duplicate, Delete 
Canvas supports the standard cut, copy, paste, duplicate, and delete editing 
features. You can only paste connections if the two ends of the connection are part 
of the pasted, cut, or copied selection. For example, if you copy one component 
and its connections, you can only paste the component itself.

Select All This option selects all the objects in the diagram.
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Edit Mode, Movement Mode, Connect Ports Mode 
AMBA Designer operates in the following modes:
• Edit Mode for normal editing, for example, adding, moving, cutting, 

copying, pasting, and deleting.
• Movement Mode for moving the system around within the Diagram 

Window using the mouse.
• Connect Mode for connecting ports of components and external ports.

Note
 To exit Connect Mode and return to Edit Mode, press Esc. To temporarily 

enter Connect Mode while in Edit Mode, hold down Shift, with no 
component selected, and make a connection.

The cursor appearance changes to indicate the mode. In Connect Mode for 
example, moving the cursor over a valid connection port outlines the port in a 
green shaded pattern, and the cursor changes to the connect icon.

View menu

This menu controls the view options such as the zoom, grid, and display options.

Signal Connections, Bus Connections 
These options toggle the display of the specific connection type. When off, the 
ports and connections are not displayed.
You can also toggle the display by clicking Signal or Bus, in the toolbar.

Grid This option toggles the display of the grid.
You can also toggle the display by clicking Grid in the toolbar.

Note
 The movement of objects is bound by the Snap to Grid flag, not the display of the 

grid.

Grid Options… 
Figure 3-5 shows the Grid Options dialog box with the default values.

Figure 3-5 Grid Options dialog box

The Grid Options dialog box contains the following options:
Show Grid 

Show the grid in the diagram with the specified options.
Default = off.

Snap to Grid 
When moving or resizing, snap the object to the grid boundary.
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Default = on.
Grid Horizontal Spacing, Grid Vertical Spacing 

The horizontal and vertical distance between grid points, in pixels, 
with a zoom of 100%.
Default = 10.

Grid Point Diameter 
The diameter of the grid points in pixels with a zoom of 100%.
Default = 1.

Select Point Color… 
The color of the grid points. Click Select Point Color... to display the 
Select color dialog box. You can choose a basic color or define your 
own custom color for the grid points.
Default = gray.

Reset to Default 
Click Reset to Default to reset all the values back to the default 
settings.

Zoom In, Zoom Out 
These options zoom in and out of the diagram. The step size change depends on 
the current zoom level.

Set Zoom to 100% 
Resets the zoom level to the default of 100%.

Zoom to Fit Sets the zoom level so that the entire diagram fits into the Diagram Window.

Set Zoom… Opens the Set Zoom dialog box that enables you to set the amount of zoom. You 
can set the zoom in the range 10%-500%.

Center on Selected Object(s) 
Centers the Diagram Window over the selected object or objects.

Center Diagram 
Centers the Diagram Window over the center of the system component.

Insert menu

Add Component… 
Displays the Select Component dialog box that contains all the available 
components that you can add to the diagram.
See Adding a component to the Diagram Window on page 3-32.

Add External Port… 
Opens the External Port dialog box. Use this dialog box to name and specify the 
type of port to add. The tools remember the last port and type of port you select 
so that the next time the dialog box opens, it displays your previous choice.
See Adding an external port to a system on page 3-41.

Add Label Sets the mouse cursor to a default label. To add a label, move the label to the 
location you require, and left-click. Canvas displays the Label Properties dialog 
box to enable you to change the label text and properties.
See Label Properties dialog on page 3-63.
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Add Connection... 
Opens the Create IP-XACT Connection dialog box. To add a connection, select 
the component instances and the ports to be connected using the drop-down lists. 
You can choose to:
• include only unconnected ports in the drop-down lists
• generate the connection name automatically or enter your own.
See Create IP-XACT Connection dialog on page 3-65.

Object menu

Auto Route Connection 
Removes any points you placed manually, or any line segment end points you 
moved manually from the connection, and reroutes the connection using the 
auto-routing features.

Mirror External Port 
Switches the direction of drawing the external port. However, it does not reverse 
the signal direction, so a master port remains a master port.
See External ports on page 3-40.

Enable/Disable Port 
In some cases, you might not use certain ports, or you might not require 
connections to certain ports. Because the tools check that all ports are connected, 
these ports cause an error or warning message. Using this option, you can disable 
such ports and avoid the error or warning messages. Canvas displays a disabled 
port in gray.

Hide Port, Unhide Port 
Hide Port disables the selected port and makes it invisible in the Diagram 
Window. To recover a hidden port, select Object → Unhide Port.

Component Display Options… 
AMBA Designer contains the following options for displaying components:
• Display Title Bar
• View Component Name
• View Logo.
The component name option affects how the title bar portion of the component 
appears. Figure 3-6 shows an ARM component with all options enabled.

Figure 3-6 All component display options enabled

Figure 3-7 on page 3-12 shows the ARM component with all display options 
disabled.
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Figure 3-7 All component display options disabled

Rename… Opens a dialog box in which you can enter a name for the object. Each object in 
the system must have a unique name. The system checks that the name of the 
object is unique, and notifies you if it is not.

Component Information… 
Opens a Component properties information box listing the component name and 
library path.

Design menu

IP-XACT RTL Stitching... 
Opens the RTL Design Flow Manager dialog box for RTL stitching. See 
Figure 3-8.

Figure 3-8 IP-XACT RTL Stitching process

See How to stitch components on page 2-17 for details of the stitching process.

Tools menu

Auto Route All Connections 
Performs the autoroute for every connection in the diagram.

IP-XACT Connections... 
Lists all of the IP-XACT connections in the system.

Add IP-XACT Component to Component Library... 
Opens the Component Library Repository Wizard that Figure 3-9 shows.

Figure 3-9 Component Library Repository Wizard
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Enter or browse to the directory where the IP-XACT (xml) source for the 
component is located and click Next to display the next dialog box in the Wizard. 
Select the Component Library Repository to add the component to. You can 
choose to enter either the absolute or relative path to the Component Library 
Repository location or click Browse to locate it. See Figure 3-10.

Figure 3-10 Component Library Repository selection dialog box

Click Next to display the next dialog box in the Wizard. This provides a summary 
of the source and destination to be used. See Figure 3-11.

Figure 3-11 Component Library Repository summary dialog box

If the details are correct, click Finish to add the IP-XACT component to the 
Component Library. If it is necessary to change any entries, click Back to display 
the required dialog box. You can cancel the Wizard at any time by clicking 
Cancel in any of the dialog boxes.

Note
 If the destination is a new Component Library, you are given the option to add the 

library to your preferences.

Manage Component Library… 
Opens the Component Library category of the Preferences dialog box. See:
• File menu on page 3-7
• General Component Library preferences on page 3-55.

Window menu

Main ToolBar, Zoom ToolBar 
The Main ToolBar option toggles all toolbars on or off. The Zoom ToolBar 
option toggles the zoom toolbar on or off.

Tools Window, Component Window, Hierarchy Window, Parameter Window 
These options toggle the specific tool window on or off.
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Note
 The Hierarchy Window option toggles the display of the AMBA Configuration 

Window.

The Tools Window option shows or hides all selected tool windows. This option 
must be on to enable you to view any of the tool windows.

Output Window 
Toggles the Output Window for the current system on or off.

Master Output Window 
Opens a separate dialog box that shows all the output of all the systems in a single 
window.

Next Window, Previous Window 
If more than one project is open, use these options to navigate between them.

Help menu

Help Enables you to choose from a list of PDF files to open with Acrobat Reader, 
depending on the add-ons you have licensed. The AMBA Designer (ADR-301) 
User Guide PDF file is always present in the list. When you click Help and select 
one of the files from the list, Acrobat Reader opens the file in a new window. If 
you press F1, or select the help option anywhere within the AMBA Designer tool, 
Acrobat Reader opens the AMBA Designer (ADR-301) User Guide document. 
Figure 3-12 shows an example of the Help menu options.

Figure 3-12 Help menu options

Note
 If a document that you click on is not located in the $AD_HOME/doc/ directory, 

AMBA Designer issues an error message stating that it cannot find the document.

Show All Pop-Up Help 
This option resets all the flags to show all the pop-up help that you have turned 
off.

Don't Show Pop-Up Help 
This option sets all the flags not to show any pop-up help.
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About… Opens the standard About dialog box to display version and license information.

About System… 
This displays information about the tools, Component Library, and system.

3.2.5 Status bar

The status bar displays information about menu items, toolbar buttons, and objects under the 
mouse cursor.

If you:

• Select a menu on the menu bar and use the up and down keys to select a menu item, 
Canvas displays a short description of what the action does in the status bar.

• Place the cursor over a toolbar button, Canvas displays a short description of the button 
action in the status bar.

• Place the cursor over a component in the Diagram Window, the status bar shows the 
instance name, the component name, and the type of component. See Figure 3-13.

Figure 3-13 Status bar showing component details

3.2.6 Diagram Window

This section describes the contents of the Diagram Window. Figure 3-2 on page 3-4 shows the 
Diagram Window.

The Diagram Window behaves in a similar way to a block diagram editor, or flow-charting tool. 
Use this window to:
• place components
• place external ports
• connect the objects together.

The Diagram Window displays a view of the total system diagram. If the system is small, the 
window can display the entire system. For large systems, the view is of a small portion of the 
total system. There is no limit to the size of the system other than the limits imposed by the 
operating system or computer hardware.
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Mouse cursors, tool tips, and status information

Table 3-2 shows all the cursors that the Diagram Window uses. The cursor column shows what 
the actual cursor looks like. The typical usage column shows how the cursor looks in typical use.

Canvas displays the standard tool tips and status information in the Status Bar whenever you 
select a menu item using the up-down keys, or hover the cursor over a toolbar button. Hovering 
the cursor over an object in the Diagram Window displays detailed information in the Status Bar.

Table 3-2 Mouse cursors

Cursor Typical usage Description

- This is the standard selection cursor. Moving this cursor over an object and clicking on the object 
selects that object. You can also use this cursor to lasso multiple objects.

This is the drag-and-drop cursor. If the component is in the Diagram Window, Canvas displays the 
object under the cursor.

- This is the cursor for movement mode.

This is the general cursor for actions that are invalid or not applicable.

This is one of the eight resize cursors. There is one cursor for each of the compass points and corners.

This is the cursor for selecting ports. Clicking on a port of a component selects that port and deselects 
all other ports.

This is the start connection cursor. If in connection mode, before you start a connection, this cursor 
appears when over a valid port.

This is the end connection cursor. When you have started a connection and not yet completed it, this 
cursor appears over a valid end port.

This cursor appears when you move a connection end point. This cursor appears when you select and 
place items.

This is the move connection line cursor. This cursor appears when you select points and manually place 
them.
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Scroll bars and scrolling the view port

The part of the scroll bar that moves is called the puck. The size of the scroll bar pucks for the 
Diagram Window is proportional to the amount of total system diagram within the view port, 
plus an amount equal to half the view port width around the edge of the system. You can quickly 
scroll the system mostly off the edge of the view port and add new objects into the empty portion 
revealed around the edge.

When you use the scroll bars to scroll the view port, Canvas continuously repaints the view.

Moving the view port

When Canvas is in Movement Mode, left-click and hold the mouse to move the view port within 
the system diagram. The limits to the movement are the same as the limits for the scroll bars. 
The scroll bars track the movement.

If Canvas is in edit mode, press and hold Ctrl to temporarily switch to movement mode.

Zoom

You can zoom the diagram in or out within the range of 10%-500%. When zooming out, the 
contents of the components change as the size of the components become smaller. Canvas 
attempts to display the most important information about objects when zooming out. You can 
hover the mouse cursor over an object to display its name in the status bar.

To access the zoom feature, press Shift + Ctrl, and use the left or right mouse buttons to zoom 
in or out.

Selecting objects

To select a single object, left-click the object in the Diagram Window. To select multiple objects, 
make selections while holding down Ctrl.

You can also use the lasso feature to select objects. Click and drag the mouse to select all objects 
within the lasso rectangle. Canvas includes any object that is partially contained within the 
bounding rectangle in your selection.

To clear the selection list, click in the background area of the Diagram Window. To remove a 
single object from the selection list, hold down Ctrl, and left-click the object.

To select all objects, select Edit → Select All or lasso the entire system.

Context-sensitive menus

When you right-click in the Diagram Window, a context-sensitive menu appears. The menu 
depends on what you have selected before you right-click.

If you have not selected a component, the general context-sensitive menu appears. See 
Figure 3-14 on page 3-18. The entries duplicate the functionality of the main menus.

See Main menu and toolbar on page 3-6.
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Figure 3-14 General context-sensitive menu for the Diagram Window

If you have selected a component, the component context-sensitive menu appears. See 
Figure 3-15.

Figure 3-15 Component context-sensitive menu for the Diagram Window

See Component context-sensitive menu on page 3-33 for more information.

Display options

You can disable the display of the object type, port list, and sub-component list in the Canvas 
preferences settings. See:
• Tools menu on page 3-12
• General Appearance preferences on page 3-54
• Canvas Appearance preferences on page 3-58.

Updating tool windows

When you perform an action in one window, all the other windows reflect the action, if 
applicable. For example, if you select a component in the Diagram Window, the AMBA 
Configuration Window updates with the selection, and the Parameter Window shows the 
parameters of the component you selected.
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Resizing windows

You can move the vertical separator horizontally between the Diagram Window and the tool 
windows. You can move the horizontal separators vertically between the individual windows of 
the tool windows, or between the Diagram Window and the Output Window.

3.2.7 Output Window

Canvas prints log information in the Output Window. The Output Window contains the 
following tabs:

Output The Output tab shows the status and error text related to loading systems 
or Component Libraries.

System Check The System Check tab shows status and error text related to system 
validation. Select the tab and then select Tools → Check System to 
validate the system. The Output Window might display error messages if, 
for example, a port is not connected or a library is missing.

3.2.8 Component Window

This section describes the Component Window. This window contains a list of all the available 
components that you can place in the Diagram Window.

Each component has an icon that best represents the component type and the name of the 
component. The Component Window can show either an:

Icon view Shows a grid of icons with the component name below the icon. See Figure 3-16.

Figure 3-16 Component Window icon view

In Figure 3-17, the NewP component has a NOT symbol around the component 
icon. This indicates that the component is not available for use. This can occur if 
the component is missing from the Component Library, or AMBA Designer 
cannot create it.

Figure 3-17 Component Window with bad component
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List view Shows each component on a single line with the icon and the component name on 
the left-hand side, and the component type on the right-hand side. See 
Figure 3-18.

Figure 3-18 Component Window list view

To switch between icon view and list view, right-click in the background, not over a component 
icon, in the Component Window and select the option you want from the context-sensitive 
menu. A scroll bar appears if the components do not fit in the current window size. You can also 
use the buttons in the Component Window title bar to switch between the icon view and list 
view.

The Component Window, by default, contains a single All tab that displays all the available 
components. You can add additional tabs by using the Component Window Tab Manager. See 
Customizing the tabs in the Component Window on page 3-25.

Drag-and-drop from the Component Window

To drag-and-drop a component from the Component Window:

1. Click the component you want to add to the Diagram Window.

2. Move the component over the Diagram Window to the location you want to add the 
component.

3. Release the mouse button to add the component to the diagram. Canvas prevents you from 
dropping a component on top of an object that already exists in the system.

Component Window context-sensitive menu

Figure 3-19 Context-sensitive menu for the Component Window

In the Component Window icon view, right-click the background, not over a component icon, 
to display a context-sensitive menu containing the following options:

Component Window Icon View 
Use this to toggle between the icon view and list view for the Component 
Window.
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You can also toggle this view in the AMBA Designer Preferences, and by using 
the buttons in the title bar of the Component Window.
See Main menu and toolbar on page 3-6 and General preferences on page 3-50.

Manage Tabs… 
Use this dialog box to organize the components using tabbed windows.
See Customizing the tabs in the Component Window on page 3-25.

Add IP-XACT Component to Component Library... 
This option displays the Component Library Repository Wizard.
Use this wizard to add an IP-XACT component to the Component Library 
Repository.
You can also start the wizard if you select Tools → Add IP-XACT Component 
to Component Library... from the main menu.

Refresh Component List 
This option clears the current component list in the Component Window, 
re-parses the Component Library file, and repopulates the Component Window. 
Use this to make changes related to the Component Library appear without 
restarting the tools.

Note
 The system diagrams that are currently open are not updated automatically. You 

must close and reload affected systems to see changes in the Component Library 
components.

Component context-sensitive menu

Right-click over a component in the Component Window to display the Component 
context-sensitive menu. Figure 3-20 shows the Component context-sensitive menu.

Figure 3-20 Component context-sensitive menu

The Component context-sensitive menu contains the following options:

Reload Component 
Select this option to reload the component selected in the Component Window.

Note
 Instances of the component in an opened system diagram are not updated 

automatically. You must close and reload the system to see the new component 
properties.
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IP-XACT Properties... 
Select this option to display the IP-XACT Properties dialog box for the selected 
component. Figure 3-21 shows the IP-XACT Properties dialog box.

Figure 3-21 IP-XACT Properties dialog box

The Component Info panel provides the following information:
Vendor The company providing the IP-XACT component.
Library The name of the library in which the component is located.
Name The unique name assigned to the generated component.
Version The version number of the component.
XML File Path The absolute path to the directory where the component 

XML file is located.
The window pane below the Component Info panel contains the following tabs:
Bus Interfaces 

This tab provides information about the generic name, type, and the 
VLNV of the component buses. See Figure 3-22.

Figure 3-22 IP-XACT Properties Bus Interfaces tab
Select a component bus and click View to display the IP-XACT Bus 
Interface dialog box.
The IP-XACT Bus Interface dialog box lists the specific properties and 
signal map for the selected bus. See Figure 3-23 on page 3-23.
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Figure 3-23 IP-XACT Bus Interface dialog box
Click View Bus Definition to display the IP-XACT Bus Definition 
dialog box.
The IP-XACT Bus Definition dialog box lists the generic properties 
and bus signals for the selected bus. See Figure 3-24.

Figure 3-24 IP-XACT Bus Definition dialog box

Parameters 
This tab provides information on parameters that have been assigned 
to the IP-XACT library component. See Figure 3-25 on page 3-24.
The Parameters tab lists the IP-XACT Parameter name, Range, and 
Default Value as applicable.
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Figure 3-25 IP-XACT Properties Parameters tab

Note
 You cannot edit library component parameters. See Parameter 

Window on page 3-28 for information on editing parameters for an 
instance of a component in the Diagram Window.

Signals This tab provides information about the component signals. See 
Figure 3-26.
The window lists the component signal name, direction, left and right 
connection widths, the export state, and whether the signal is assigned 
to a bus interface. Check the Show Unassigned Signals Only option 
to show unassigned signals only, in the dialog box.

Figure 3-26 IP-XACT Properties Signals tab
Select a component signal and click View to display the IP-XACT 
Signal Mapping dialog box, see Figure 3-27.

Figure 3-27 IP-XACT Signal Mapping dialog box
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The IP-XACT Signal Mapping dialog box contains the following 
panels:
IP-XACT Signal Information 

Provides information about a signal’s assigned name, 
direction, left and right widths, and whether the signal is to 
be exported and assigned to a bus interface.

Bus Interface Mapping 
Provides information about the bus interface to which the 
signal belongs, the bus signal name within the bus, and the 
bus VLNV.

Remove Component from Component Library 
This option removes the selected component from its Component Library file.

Note
 • If multiple components with the same identification exist in the active 

Component Library files then only the first one is deleted.
• Instances of the component in an opened system diagram are not updated 

automatically.

Component Window Icon View 
Use this switch to toggle between the icon view and list view for the Component 
Window.
You can also toggle this view in the AMBA Designer Preferences, and by using 
the buttons in the title bar of the Component Window.
See Main menu and toolbar on page 3-6 and General preferences on page 3-50.

Refresh Component List 
This option reloads the component by rescanning the various Component Library 
files specified in the Preferences dialog box.

Component information… 
Select this option to display the Component properties information box that lists 
the component name and the library path to the maxlib.conf library file.

Customizing the tabs in the Component Window

Canvas enables you to configure the Component Window tabs to organize the components. You 
can configure each tab to display certain types of components, modify or remove existing tabs, 
and add new ones. Component Window on page 3-19 describes the default All tab.

Right-click the background of the Component Window, or next to the tabs, and select Manage 
Tabs... from the context-sensitive menu. See Figure 3-19 on page 3-20.

Figure 3-28 on page 3-26 shows the Component Window Tab Manager which contains the 
following list views:

• The Window Tabs panel is the left-hand list and shows all the existing tabs. The 
checkboxes represent the active options.

• The Component Types panel is the central list and shows the component types of the 
currently-selected tab.
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• The right-hand list shows all available component types that do not already appear in the 
center list view. Canvas generates this list automatically from all components that are 
currently loaded.
It is possible to create new component types, for example, to add a component type that 
you have not yet used to an existing tab. Use the arrow buttons to add and remove 
component types to the selected window tab.

Figure 3-28 Component Window Tab Manager

Use the buttons in the Window Tabs panel to delete existing tabs, edit their names, or create new 
ones. Use the up and down arrows to change the order of the tabs in the Component Window.

Note
 • You cannot edit or delete the All tab. You can disable the All tab, and any custom tab, so 

that they do not appear in the Component Window, by unchecking them in the Window 
Tabs panel.

• Click Reset to set the component tabs back to their original configuration. If you have 
added custom tabs, Reset disables them without deleting them.

Component versions

AMBA Designer does not support switching between multiple versions of the same IP-XACT 
component. To use different versions of the same component, include the version string in the 
component name to differentiate them. For example, Figure 3-29 shows two versions of the 
DMC (PL340) in the Component Window.

Figure 3-29 Component Window with versions in list view

3.2.9 AMBA Configuration Window

The AMBA Configuration Window contains the following tabs:

Configurators Use this tab to view the list of components available for configuration. See 
Configurators tab on page 3-27.
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Hierarchy Use this tab to view the hierarchy of the current design. See Hierarchy tab.

Configurators tab

The Configurators tab lists all the component configurators that are available for the 
configuration. This tab shows the IP Configurator, Version, and Description for the components. 
Click a column heading to sort the list for that column.

The Configurators tab contains a context-sensitive menu. To open the context-sensitive menu, 
right-click an IP Configurator in the Configurators tab. See Figure 3-30. Use the 
context-sensitive menu to view the full Tools Window, undock the Tools Window, or show the 
Component Window, Hierarchy Window, Parameter Window, and Output Window 
independently.

Note
 The Hierarchy Window option toggles the display of the AMBA Configuration Window.

Figure 3-30 Configurators tab context-sensitive menu

Hierarchy tab

The Hierarchy tab contains a list of all the components and external ports in the system that the 
Diagram Window displays. For each component, a sub-list of all the ports and sub-components 
exists. Selecting an object in the Diagram Window also selects the object in the Hierarchy tab.
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Figure 3-31 Hierarchy tab

Left-click an object in the Hierarchy tab to highlight and center the object in the Diagram 
Window for easy location.

Right-click an object in the Hierarchy tab to display a context-sensitive menu containing 
command options specific to the object type.

Note
 The context-sensitive menu displayed is the same as the menu displayed if you click a 
component in the Diagram Window. See Figure 3-15 on page 3-18.

3.2.10 Parameter Window

The Parameter Window is not displayed by default. To display it, either:
• select Window → Parameter Window on the main menu
• right-click in the open area of the AMBA Configuration Window and select Parameter 

Window from the context-sensitive menu.

The Parameter Window contains all the parameters you can edit for the selected legacy 
component. See Figure 3-32.

Figure 3-32 Parameter Window

Note
 • If more than one object is selected, or the selected object is not a legacy component, the 

Parameter Window is blank.
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• To view the parameters assigned to an IP-XACT component, right-click the component 
instance in the Diagram Window and select Component IP-XACT Properties... from 
the context-sensitive menu. The assigned parameters for the component are listed in the 
Parameters tab of the IP-XACT Properties dialog box.

The Parameter Window contains the following columns:

• The Parameter column lists all the parameters that you can edit.

• The Value column contains the current values for all the components.

• The default column contains a button to reset the value back to the default value. If the 
value is currently default, the button is disabled and the window displays a tilde 
symbol, ~. Otherwise, the button displays Reset.

• Parameters that you can edit are represented by a check in the fourth column.

• The Type column indicates whether the parameter is a Boolean or numerical variable.

Note
 • To see all the read-only parameters, and parameters that you can edit associated with a 

legacy component, right-click the component and select Component Information… 
from the context-sensitive menu.

• Not all components contain parameters that you can modify. If you select Component 
Information... for a component that does not have parameters you can modify, AMBA 
Designer displays the No properties available dialog box.

Editing parameters

For legacy components, display the Parameter Window and double-click the parameter value 
you want to modify. See Figure 3-32 on page 3-28. Modify the parameter value, and press Enter 
to accept the value, or press Esc to cancel the change.

For IP-XACT components, right-click the component instance in the Diagram Window and 
select Component IP-XACT Properties... from the context-sensitive menu to open the 
IP-XACT Properties dialog box. Select the Parameters tab. See Figure 3-33.

Figure 3-33 IP-XACT Properties dialog box, Parameters tab

Select the parameter to edit and click Edit. The Enter IP-XACT Parameter dialog box opens. 
See Figure 3-34 on page 3-30.
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Figure 3-34 Enter IP-XACT Parameter dialog box

Edit the attribute that applies to the selected parameter and either click OK to save the changes 
and close the dialog box, or click Cancel to close the dialog box without saving the changes.

Note
 IP-XACT parameters are not supported for IP-XACT 1.2 component definition files.
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3.3 Using components
This section describes components and how to use them in a system. It contains the following 
sections:
• Adding a component to the Diagram Window on page 3-32
• Component info box on page 3-33
• Component context-sensitive menu on page 3-33
• Ports on page 3-35
• Making connections between components on page 3-36
• External ports on page 3-40
• Component icons displayed in the tool windows on page 3-43.

Figure 3-35 shows a component as it appears in the Diagram Window.

The title bar shows the instance name of the component and the component name in parentheses.

Figure 3-35 Component description

Figure 3-36 on page 3-32 shows an unselected and a selected component. The selected 
component has a different colored title bar area, and resize control points.

Instance name Component name

Signal
slave ports

Component info

Component iconResize handle

Signal
master ports
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Figure 3-36 Component and selected component

3.3.1 Adding a component to the Diagram Window

To add a component to the Diagram Window, perform one of the following actions:

• drag a component from the Component Window to the Diagram Window

• copy and paste an existing component in the Diagram Window

• click Comp in the toolbar

• right-click the Diagram Window and select Add Component... from the context-sensitive 
menu

• select Insert → Add Component... from the main menu.

The last three methods display the Select Component dialog box. See Figure 3-37.

Figure 3-37 Select Component dialog box
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The Select Component dialog box contains an Instance Name field where you can enter the 
instance name of the component. If you do not enter a name, Canvas creates a unique name for 
the component. Make a selection and click OK to close the dialog box.

After the Select Component dialog box closes, the component appears in the Diagram Window 
at the mouse cursor. Move the mouse to position the component in the Diagram Window and 
left-click to place the component.

Note
 You cannot place a component on top of another object in a system. If you attempt to do this, a 
Help box opens that contains details of the error and help information.

3.3.2 Component info box

When the mouse hovers over the i box in the top right-hand corner of a component, the cursor 
changes to a question mark. See Figure 3-38. This simplifies finding the info box in large 
diagrams at small zoom factors.

Figure 3-38 i box focus

Click on the info box to display the main properties of the component. See Figure 3-39.

Figure 3-39 Component info box

The information in the info box is displayed with the same font size regardless of the zoom 
factor of the diagram.

3.3.3 Component context-sensitive menu

Right-click on a component to display a context-sensitive menu. See Figure 3-40 on page 3-34.
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Figure 3-40 Component context-sensitive menu in the Diagram Window

The following entries perform the same functions as the corresponding entries in the Edit menu:
• Cut
• Copy
• Delete.

See Edit menu on page 3-8.

The following entries perform the same functions as the corresponding entries in the Object 
menu:
• Rename…
• Unhide Port.

See Object menu on page 3-11.

Disable All Unconnected Ports 
Disables every unconnected port for the component.

Note
 If a hidden port has been revealed by using the Unhide Port option, the port is 

shown in gray.

Hide All Disabled Ports 
Hides disabled ports in the component.

Note
 You can override this action for specific ports by using the Unhide Port option.

Component Display Options… 
This entry performs the same function as the corresponding entry in the Object 
menu. See Object menu on page 3-11.

Replace Selected Component… 
Replace selected objects with other similar objects. AMBA Designer attempts to 
reconnect all connections to the same ports of the new component. If the same 
port does not exist, AMBA Designer deletes the connection. The tool preserves 
the size of the component, but not the name.

Caution
 Use this option with care. It might adversely affect the design of your system.
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Component Information… 
• For legacy components, this option displays the Edit Component Properties 

dialog box that enables you to view and edit the object parameters. See Edit 
Parameters dialog on page 3-66.

• For IP-XACT components, this option displays the Component properties 
information box that lists the Component name and Library path where the 
component configuration is located.

3.3.4 Ports

Figure 3-41 shows the component port types.

Note
 AMBA Designer does not support IP-XACT Phantom ports.

Figure 3-41 Component port types

Master ports always point out of the component and slave ports always point into the 
component.

You can move master and slave ports around the edges of the component as Figure 3-42 shows.

Figure 3-42 Permitted port locations

Bus interface connections appear with thick lines, and signal and clock connections appear with 
thin lines. See Figure 3-43 on page 3-36. You must connect:
• bus interface port outputs to bus interface port inputs of the same type
• signal port outputs to signal port inputs.

Bus interface
(slave)

Bus interface
(master)

Signal
(in)

Signal
(out)
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3.3.5 Making connections between components

Figure 3-43 shows how to make a connection to an external port or a port on another component. 
Click Connect on the main toolbar, or select Edit → Connect Ports Mode from the main 
menu. Place the cursor over the first port to be connected. The cursor changes to the Connect 
Ports Mode cursor and the port is highlighted. Left-click the port and move the cursor to the 
second port to be connected. The Canvas automatically creates an orthogonal wire as the cursor 
is moved to the second port. To control the points at which the orthogonal wire changes 
direction, left-click the wire to create anchor points. To complete the connection, place the 
cursor over the second port to be connected, and when the port is highlighted, left-click the 
mouse to complete the connection. You can cancel the connection by pressing Esc any time 
before left-clicking the second port connection.

Note
 • If you attempt to connect together ports that are not of the correct types, the connection is 

not made, and a Help box appears listing the error and help information.

• Bit-slice connections and tie-offs are supported through the use of IP-XACT 1.4 ad-hoc 
connections. See Ad-hoc connections.

Figure 3-43 Making a new connection

Ad-hoc connections

The tool supports IP-XACT 1.4 for:
• bit-slice connections, see Bit-slice connections
• tying off input ports, see Tying off input ports on page 3-38
• unhiding ports within a bus interface, see Unhide ports on page 3-39.

Bit-slice connections

To make a bit-slice connection from a signal port to other component or external ports, perform 
the following steps:

1. In the Canvas, select Connection Mode. Make all the necessary bit-slice connections 
from the signal port to be split to the corresponding components or external ports. See 
Figure 3-44 on page 3-37.
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Figure 3-44 Multiple bit-slice connections

2. In the main menu, select Tools → IP-XACT Connections.... The IP-XACT Connections 
dialog box opens listing all the IP-XACT connections for the system. Figure 3-45 shows 
the listing for the system that Figure 3-44 shows, before editing. By default, the port 
signals are full bit-width connections, that is, no bit-slices have been specified.

Figure 3-45 IP-XACT Connections listing before editing

3. To create a bit-slice, edit the L and R values in the port listing to define the bit range 
required for each bit-slice.

Note
 The following ad-hoc connections are not supported:

• signals from external bus interfaces
• non-contiguous bit-slicing of two ad-hoc signals connected together.

Figure 3-46 shows the edited IP-XACT connections for the system that Figure 3-44 
shows.

Figure 3-46 IP-XACT Connections listing after editing
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4. Click OK to save the new L and R signal port values and close the IP-XACT Connections 
dialog box. Click Cancel to close the dialog box without saving the changes.

Tying off input ports

Note
 For an input port that is tied-off, the port color changes to solid light green.

To tie-off an input port, right-click the input port to display the port context-sensitive menu. See 
Figure 3-47.

Figure 3-47 Port context-sensitive menu

Select Create Tied Value from the menu to display the IP-XACT Connections dialog box that 
Figure 3-48 shows.

Figure 3-48 IP-XACT Connections dialog box

By default, the port is given a tied value of 0. To apply the default value, close the dialog box 
by clicking either OK or Cancel.

To change the default tied value for a port, left-click the port listing below the Tied Value header. 
In the text entry field that appears, enter the new tied value, and click OK to apply the new value 
and close the dialog box. To close the dialog box without changing the default tied value, click 
Cancel.

To delete a port tied value, from the main menu select Tools → IP-XACT Connections... to 
display the IP-XACT Connection dialog box. Left-click the port listing and click Delete Tied 
Value. Click OK to delete the tied value and close the dialog box. To close the dialog box 
without deleting the tied value, click Cancel.
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Unhide ports

Note
 By default, all the signals that are part of a component bus interface are hidden. You can use, 
connect, and tie-off such signals in an ad-hoc manner by first unhiding the required signal port, 
and then using the normal connection and tie-off methods. For an unhidden port, the color is 
solid dark grey. The unhiding is a GUI-only feature because the signal port that was hidden can 
now be seen on the Canvas. The port connectivity at this stage remains unchanged.

You can access, and either tie-off or connect as an ad-hoc connection to other component ports 
and external ports, ports that are normally hidden as part of a bus interface. To unhide a port, 
either right-click on a component in the Diagram Window, or in the Hierarchy tab in the AMBA 
Configuration Window, and select Unhide Port from the component context-sensitive menu. 
The Select port to show dialog box appears as Figure 3-49 shows.

Figure 3-49 Select port to show dialog box

Note
 If a component has both a bus interface and a signal with the same name, then you cannot unhide 
the signal to show it on the Canvas for use as an ad-hoc connection.

Select the port required from the port list and click OK to unhide the port and close the dialog 
box. Click Cancel to close the dialog box without unhiding a port. The port appears in the 
component outline and you can reposition it by clicking and dragging it to the new position. You 
can now make an ad-hoc connection or tie-off to the port. See Figure 3-50.

Figure 3-50 Ad-hoc connection to an external port
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Note
 If a single physical port is mapped to multiple bus interfaces in a component IP-XACT file, then 
when using the Unhide Port option, the component that represents this IP-XACT file in the 
Canvas shows this physical port mapped to the first bus interface to which it is mapped, and 
displays the physical port only once.

You can also expand the component view in the Hierarchy tab of the AMBA Configuration 
Window and right-click an individual port to display the component context-sensitive menu, 
then select Unhide Port.

If the unhidden port is a signal that is part of a bus interface then:

• if the port is left unconnected, but the bus interface is connected, then the signal is 
connected according to the original bus interface connection

• if the port is connected, then the resulting Verilog code connects the signal both according 
to this new connection, and the original bus interface connection

• if the port is tied-off, then the new tie-off takes precedence over the original bus interface 
connection and the resulting Verilog code ties off the signal.

3.3.6 External ports

External ports connect hierarchical systems. A system that you intend to instantiate within a 
higher-level system must have external ports. A top-level system or a flat system typically does 
not have external ports.

The external ports are arranged and marked as follows:
• Bus interface ports 

These appear solid black.
Signal ports 

These appear shaded.

• The left-hand side ports are slave ports, and the right-hand side ports are master ports. 
Master ports have a triangular port symbol within the rectangular portion of the external 
port symbol.

Figure 3-51 shows the external port types.

Figure 3-51 External port types

When you instantiate a stitched system as a component, each external port appears as a port 
symbol inside the component. See Figure 3-52 on page 3-41.
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Figure 3-52 Stitched system showing external ports

When you add a stitched system to the Component Library, it appears in the Component 
Window with a system icon and the name you gave it when you saved it. Figure 3-53 shows the 
example system saved as NIC_301_PL340.

Figure 3-53 Saved stitched system in Component Window

Adding an external port to a system

To add an external port to a system that matches the component you have selected:

1. Click Edit on the toolbar, or select Edit → Edit Mode.

2. Select a port on the component by hovering the mouse cursor over it. The cursor changes 
to a hand symbol when the port is in focus.

3. Right-click to display the context-sensitive menu for ports.

4. Select Create External Port.
Canvas automatically creates an external port and connection with the same type, name, 
and orientation in the Diagram Window.

5. Drag the external port symbol to the required position in the Diagram Window and 
left-click to complete the action. Press Esc at anytime before left-clicking to cancel the 
action.
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To add a new port to a system, and to specify the name and the type:

1. Open the External Port dialog box by performing one of the following actions:
• click Port on the toolbar
• select Insert → Add External Port
• right-click in the Diagram Window and select Add External Port from the 

context-sensitive menu.
AMBA Designer displays the External Port dialog box. See Figure 3-54.

Figure 3-54 External Port dialog box

2. Select the type of port from the radio buttons on the left-hand side of the dialog box.

3. Select the direction for the port from the radio buttons on the right-hand side of the dialog 
box.

4. Enter a name for the port in the Name text box.

5. Click OK to create the port and display it in the Diagram Window.

6. To change the direction of the port, right-click the external port and select Mirror 
External Port from the context-sensitive menu. See Figure 3-55.

Figure 3-55 External Port context-sensitive menu

Figure 3-56 shows a master port and the resulting mirrored version.

Figure 3-56 Original and mirrored external port

OriginalMirrored
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7. To change the name of an external port either, double-click the port, or right-click the port 
and select Rename... from the context-sensitive menu to display the Rename Object 
dialog box. Enter the new name and click OK to save the new name and close the Rename 
Object dialog box, or click Cancel to close the Rename Object dialog box without saving 
the changes.

8. Change to connect mode and connect the new external port to a component port in the 
system.

Note
 Each port must have a unique instance name. You can use the normal copy and paste actions to 
duplicate a port and then Canvas assigns it a unique name by adding an underscore and 
numerical suffix to the original port name.

3.3.7 Component icons displayed in the tool windows

Figure 3-57 shows the icons that are used in the Hierarchy tab of the AMBA Configuration 
Window.

Figure 3-57 Icons used in the Hierarchy tab

The icons in Figure 3-57 represent, from left to right:
• component
• external port
• port.

Figure 3-58 shows the icons that the Component Window uses.

Figure 3-58 Icons used in the Component Window

The icons in Figure 3-58 are used as follows:

• the smaller component icon appears to the left of the component name in the Component 
Window list view

• the larger icon appears above the component name in the Component Window icon view.
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3.4 IP-XACT stitching
AMBA Designer supports the stitching of ARM components that have IP-XACT descriptions. 
This section describes IP-XACT stitching.

It contains the following subsections:
• About IP stitching
• Using IP-XACT stitching
• Directory structure on page 3-46.

Note
 AMBA Designer does not support the stitching of third-party IP-XACT components.

3.4.1 About IP stitching

The IP stitching feature enables you to take AMBA components from the Component Library, 
place them on the Diagram Window and define their bus interconnections at a high level. 
AMBA Designer generates a top-level Verilog RTL file as a result. This means that you are not 
required to interactively connect each of the interfaces together, and it eliminates a 
labor-intensive and error-prone task.

To ease system integration, you can select the Export all unconnected option and AMBA 
Designer shows any unresolved connections in the top-level file interface. See Signal Options 
on page 3-45 for more information.

All new ARM AMBA IP is validated before release to ensure that it is compatible with the 
AMBA Designer IP stitching design flow.

3.4.2 Using IP-XACT stitching

This section describes how to use IP-XACT stitching and contains the following subsections:
• IP-XACT_Stitching tab
• Limitations on page 3-46.

IP-XACT_Stitching tab

Figure 3-59 shows the AMBA Designer - RTL Design Flow Manager Preferences dialog box.

Figure 3-59 RTL Design Flow Manager Preferences dialog - IP-XACT_Stitching tab
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 3-44
ID030610 Non-Confidential



Canvas Reference 
The configuration options are:

Flags

Ignore IP-XACT Bus Definitions VLNV Version Fields 
When selected, bus interface version fields on components are not compared 
against bus definition versions when checking for bus compatibility.

Run IP-XACT Stitching Process in Verbose Mode 
When selected, an extended messaging mode is used that provides additional 
progress information.

Create verbose comments in the generated RTL 
When selected, basic comments are added to the RTL during the stitching 
process.

Run IP-XACT Stitching Process in Strict Mode 
When selected, forces a strict strategy to be used when stitching. This is useful for 
IP-XACT design verification, and the following policies apply:
• failure when ID widths do not match in NIC-301-only designs
• failure when an invalid default value is detected for input or bidirectional 

signals, in IP-XACT component definitions
• failure when connected signals do not have the same size, or the same left 

and right bits
• additional warning messages are output.

Output VC file 
When selected, a <design name>.vc file is generated at the same location as the 
top-level <design name>.v file. The .vc file contains references to all the .v files, 
directories, and other directory dependencies, and you can use it to compile the 
entire design.

Auto Add Stitched System to Component Library 
When selected, AMBA Designer adds the stitched system to the Component 
Library.

Absolute path for .v files in generated IP-XACT file 
When selected, the generated IP-XACT file includes the absolute path to the .v 
files instead of the relative path.

Signal Options

Use instance names in nets 
When selected, the instance name of the components being connected are used as 
part of the net name.

Export all unconnected 
When selected, all the unconnected signal ports are exported to the top-level of 
the design. This is equivalent to manually creating external ports for all the 
unconnected signal ports in the design.

Note
 Only signal ports, not bus interface ports, are exported to the top-level of the 

design.
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Limitations

In accordance with IP-XACT rules, connections are supported only between master and slave 
interfaces.

Note
 Connections must be wired point-to-point connections and no bus interface fanout is supported. 
For example, on the NIC-301 AMBA Interconnect APB master interfaces, AMBA Designer 
extracts each individual APB slave slot so that each of these slots can be stitched individually.

3.4.3 Directory structure

Since the release of AMBA Designer r2p1, a fixed, internal directory structure stores IP-XACT 
files. Information stored under this structure can be different, depending on the nature of the 
design.

This section describes the directory structures for the following design types:
• Configurable ARM AMBA IP
• Stitched ARM AMBA IP designs on page 3-47.

Configurable ARM AMBA IP

AMBA Designer creates the directory structure that Figure 3-60 shows, under your designs 
directory when the following are true:

• you invoke the RTL Design Flow Manager on ARM configurable AMBA IP, for example, 
the AMBA Interconnect NIC-301, or the AMBA DMC-340

• the RTL generation process has completed successfully.

Figure 3-60 Directory structure

Note
 • The directory structure in Figure 3-60 assumes that you have created a component called 

<My_Config>.

testbench/

logical/
<My_Config>/

spirit/

<My_Config>_RTL/

verilog/
spirit_stitching/

busdefs/
componentdefs/
configs/
currcomponentdef/
designfile/
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• The output of each configurable IP generator might be different to the structure that 
Figure 3-60 on page 3-46 shows, and additional directories might be present. However, 
only the directories that this section describes are important when working with 
IP-XACT.

<My_Config>_RTL/ 
This directory is named after the component, followed by _RTL, for example, 
NIC-301_RTL, and stores all the generated information for this component.

logical/ Contains the generated RTL for the <My_Config> component.

logical/<My_Config>/spirit/ 
Contains the IP-XACT definitions of the <My_Config> component.

spirit_stitching/ 
Top-level output directory for the IP-XACT files corresponding to the 
configuration.

spirit_stitching/currcomponentdef/ 
Contains the IP-XACT definition of the <My_Config> component.

Note
 For legacy purposes only. For new stitched designs, the top-level IP-XACT is 

now generated in the logical/<My_Config>/spirit/ directory.

Example 3-1 IP-XACT definition of a PL301 component

<?xml version="1.0" encoding="UTF-8"?>
<spirit:component xmlns:spirit="http://www.spiritconsortium.org/XMLSchema/SPIRIT/1.2"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xalan="http://xml.apache.org/xalan"
xsi:schemaLocation="http://www.spiritconsortium.org/XMLSchema/SPIRIT/1.2
http://www.spiritconsortium.org/XMLSchema/SPIRIT/1.2/component.xsd">

<spirit:vendor>arm.com</spirit:vendor>
<spirit:library>AMBA3</spirit:library>
<spirit:name>pl301_a3bm_My_Config</spirit:name>
<spirit:version>r1p1</spirit:version>
<spirit:busInterfaces>
<spirit:busInterface>
<spirit:name>s00_axi_64</spirit:name>
<spirit:busType spirit:vendor="amba.com" spirit:library="AMBA3" spirit:name="AXI" spirit:version="r1p0"/>
<spirit:slave/>

.

.

Stitched ARM AMBA IP designs

The IP stitcher uses the standard directory structure that Figure 3-60 on page 3-46 shows to store 
the required IP-XACT input files, before they are processed. The IP-Stitcher output is stored in 
the structure that Figure 3-61 on page 3-48 shows, and this section describes it.
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Figure 3-61 Directory structure for stitched designs

<My_Stitched_Design>_RTL/ 
This directory is named after the design, followed by _RTL, for example, 
my_design1_RTL, and stores all the generated information.

logical/ Top-level directory of the IP-Stitcher RTL output.

logical/<My_Stitched_Design>/spirit/ 
Contains the top-level IP-XACT component definition file (.xml).

verilog/ Contains the RTL for this design that the IP-Stitcher generates.

Example 3-2 RTL for a design

///////////////////////////////////////////////////////////////////////////////
// **** Top-Level Verilog file auto-generated by AMBA Designer ****
// Created: Mon Apr 20 19:19:16 2009
///////////////////////////////////////////////////////////////////////////////
module My_Stitched_Design (
// Exports from module for My_Config_1_0_
CLKfuj_1_1_0_,
RESETnfuj_1_1_0_,
TZPROTfuj_1_1_0_,
ARADDRs00_axi_64fuj_1_1_0_,
ARLENs00_axi_64fuj_1_1_0_,
.
.

spirit_stitching/ 
Top-level directory for all IP-XACT files.

configs/ Contains all the configuration files from configurable AMBA IP components that 
might be present in the design, but not IP-XACT.

Example 3-3 Configuration file for a PL301 component

<!DOCTYPE cfgfile SYSTEM "cfgfile.dtd">

<cfgfile>
<product_version_info

component_name = "pl301_a3bm_My_Config"
product_code = "pl301"
major_group = "bu"
minor_code = "00000"
major_revision = "1"

testbench/

logical/
<My_Stitched_Design>/

spirit/

<My_Stitched_Design>_RTL/

verilog/
spirit_stitching/

configs/
currcomponentdef/
designfile/
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 3-48
ID030610 Non-Confidential



Canvas Reference 
minor_revision = "0"
major_version = "00"
part_quality = "rel"
minor_version = "1">

</product_version_info>
.
.

currcomponentdef/ 
For legacy purposes only.

Note
 For new stitched designs, the top-level IP-XACT is now generated in the 

logical/<My_Config>/spirit/ directory.

Example 3-4 IP-XACT description of current design

<spirit:component xsi:schemaLocation="http://www.spiritconsortium.org/XMLSchema/SPIRIT/1.2
http://www.spiritconsortium.org/XMLSchema/SPIRIT/1.2/component.xsd"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:spirit="http://www.spiritconsortium.org/XMLSchema/SPIRIT/1.2" >

<spirit:vendor>arm.com</spirit:vendor>
<spirit:library>AMBA3</spirit:library>
<spirit:name>My_Stitched_Design</spirit:name>
<spirit:version>r2p2_00rel0</spirit:version>

.

.
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3.5 AMBA Designer Preferences dialog
Use the AMBA Designer Preferences dialog box to configure preferences. To open the AMBA 
Designer Preferences dialog box, select File → Preferences... from the main menu. Figure 3-62 
shows the AMBA Designer Preferences dialog box.

Figure 3-62 AMBA Designer Preferences dialog box

The AMBA Designer Preferences dialog box is a standard tree view dialog box, with major 
features on the left-hand side, and details of the major features on the right-hand side.

The preferences are grouped as follows:
• General. See General preferences:

— Appearance. See General Appearance preferences on page 3-54.
— Component Library. See General Component Library preferences on page 3-55.

• Canvas. See Canvas preferences on page 3-56:
— Appearance. See Canvas Appearance preferences on page 3-58.
— Diagram. See Diagram Window preferences on page 3-58.
— IP-XACT. See Canvas IP-XACT preferences on page 3-60.

3.5.1 General preferences

In Figure 3-62, the General preferences contains the following panes:
• General on page 3-51
• Home Directory on page 3-51
• Text Editor on page 3-51
• Browser on page 3-51
• Design Preferences on page 3-51.
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General

The General pane contains the following options:

Display Tool Tips 
This option enables or disables all the tool tips in the application.
Default = on.

Show Statusbar 
This option toggles the display of the status bar at the bottom of the Canvas 
window.
Default = on.

Show Splash Screen on Startup 
This option enables you to show or hide the splash screen on startup.
Default = on.

Use Last Visited Directory for Open/Save 
Select this option to automatically return to the last directory you used to open or 
save a file.
Default = off.

Home Directory

The Home Directory pane enables you to specify the path to your home directory. This directory 
is part of the AMBA Designer search path.

Text Editor

The Text Editor pane enables you to specify the text editor that AMBA Designer invokes when 
you select Edit Configuration File… from the context-sensitive menu of a component.

Browser

The Browser pane enables you to specify the web browser AMBA Designer invokes when you 
open hypertext documents.

Design Preferences

Click Design Preferences... to edit the design preferences. This opens the Design Preferences 
dialog box. See Figure 3-63 on page 3-52.
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Figure 3-63 General Design Preferences dialog box

To change the defined paths or file, perform one of the following actions:

• Enter the new directory path in the associated field then click OK to save the preferences 
and close the Design Preferences dialog box.

• Click Browse... to open a file browser dialog box. Use this dialog box to:
1. Navigate to the appropriate directory or file.
2. Select the appropriate directory or file.
3. Click OK to close the file browser dialog box.
4. Click OK to save the preferences, and close the Design Preferences dialog box.

AMBA Designer saves the preferences in the AMBA_Designer_Prefs.ini file. Figure 3-64 shows 
the location of the .ini file.

Figure 3-64 Location of AMBA Designer preferences file

In Figure 3-64, <x> represents the major revision number and <y> represents the minor revision 
number of AMBA Designer, for example, 3.0.

The preferences are:

Global User Preferences 
The path to the location of the global preferences.

Local User Preferences 
The path to the location of your local preferences.

Generated Design Model Path 
After you configure an AMBA component, AMBA Designer generates the 
IP-XACT component and saves it in this directory.

AMBA_Designer/

home/
<user>/

.ARM/

<top-level directory>/

<x>.<y>/
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During the RTL generation process, the tools create the relevant RTL directory 
structure for the AMBA component in this directory. AMBA Designer uses this 
directory structure to save the RTL files that it generates.

Generated Component File 
AMBA Designer uses the Component Library file to store the configured 
components in the AMBA Designer Component Library. The configuration 
process for AMBA components consists of the tools writing the resultant 
IP-XACT and Verilog files to the Generated Design Model Path directory.
This file contains the library configuration entry information for generated 
components that you have added to the IP-XACT Component Library.

Design Configuration Target Path 
This directory contains the design configuration files. These files contain the 
parameter, address, and sparse information that AMBA Designer uses to generate 
the AMBA component.

Generated Design Permissions 
This field enables you to apply file protection bits, and optionally, assign a default 
group. The tools use these settings each time you generate new RTL for a 
component or system. The field provides a summary of the permissions for the 
following categories:
• User
• Group
• Other.
It also shows the name of the user group. To change these permissions, click 
Set.... This opens the AMBA Designer - Generated Design File Permissions 
dialog box. See Figure 3-65.

Figure 3-65 Generated Design File Permissions dialog box

Use this dialog box to change:
• The permissions for each of the categories.
• The user group. You can select this from the drop-down list.

Note
 • For Linux, the OS restricts the list of groups available to those groups that 

you, the current user, are subscribed to.
For Solaris, all these tools list all the user groups, but you might not be able 
to make selections outside your subscribed groups.

• These settings only apply to newly-generated IP. If you change these 
settings between sessions for RTL generation, the tools do not apply them 
retrospectively.
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Generated Design Logfile 
The path to the location of the generated logfile. To enable this option, select the 
check box.

3.5.2 General Appearance preferences

Figure 3-66 shows the Appearance area under the General area of the AMBA Designer 
Preferences dialog box. Use this dialog box to control the appearance of text and icons on the 
application windows.

Figure 3-66 General Appearance Preferences dialog box

The Appearance area contains the following panes:
• Tool Bar Options
• Magnify Object Delay
• Fonts on page 3-55.

Tool Bar Options

The toolbar options are:

Use Large Icons 
Select this option to use the large version of the toolbar icons instead of the small 
versions.
Default = off.

Display Text Labels 
Display the name of the toolbar button below the icon of the button.
Default = on.

Magnify Object Delay

If the zoom level is set to less than 70%, hovering the cursor over a component in the Diagram 
Window magnifies the component to its original size, after a delay. Use this setting to adjust the 
delay before the component appears magnified.
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Fonts

Use the controls in the Fonts pane to select the font type and size for text displayed in the 
application windows:

Select Font… 
Click Select Font... to select the display fonts for the System, Output Window, 
Components, Component Ports, and External Ports.
The system font is the font that appears in the application window. The other fonts 
correspond to the fonts that appear in the objects in the diagram.

Note
 The appearance of fonts in the interface depends on the fonts available on your 

system.

Reset Fonts to Default 
Use this button to reset all the fonts to their original default settings.

3.5.3 General Component Library preferences

Figure 3-67 shows the Component Library area under the General area of the AMBA Designer 
Preferences dialog box.

Figure 3-67 General Component Library Preferences dialog box

Working Directory 
Specify where the tools search for the Component Library files. AMBA Designer 
uses the components in these files to fill the list in the Component Window. You 
can choose from the following options:
• Use current directory. This is the directory in which AMBA Designer starts. 

This is the default setting.
• Use the specified directory.
• Use the location of the current AMBA Designer project, *.adg, file for the 

working directory.
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 3-55
ID030610 Non-Confidential



Canvas Reference 
Note
 Changing the working directory requires a refresh of the Component 

Window.

Additional Component Configuration Files 
You can manually add component configuration files. The tools search for these 
files when they initialize a component. To change the priority of a file, highlight 
the file and click the up and down arrows to the right of the file list. Files near the 
top of the list have a higher priority than those near the bottom.

Note
 If duplicate components exist, only the first one is available.

Search order for Component Library (CONF) files

The tools search the available Component Library files for components in the following order:

1. Files specified in the script file for batch mode.

2. Files specified on the command line when you started AMBA Designer.

3. Files in the specified working directory. By default, this is the current directory.
Use the Working Directory option to specify the current working directory.

4. Files added in the Additional Component Configuration Files pane of the Component 
Library area of the AMBA Designer Preferences dialog box.
Use the Additional Component Configuration Files options to add or delete search 
paths, or to change the search order.

3.5.4 Canvas preferences

Figure 3-68 shows the Canvas area of the AMBA Designer Preferences dialog box.

Figure 3-68 Canvas Preferences dialog box
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Application Options

The Application Options pane contains the following options:

Output AMBA Designer Messages to Text File 
Turn on the logging of messages to the application output file. The name of the 
file is AMBA DesignerMessageOutput.txt.
Default = on.

Reload last project on application startup 
Reload the last project. The last project is the first project in the history list in the 
File menu.
Default = off.

Save As dialog adds sub-directory automatically 
Automatically add a sub-directory to the current directory so that all the project 
files go into the sub-directory by default.
For UNIX and Linux, default = off.

Save Options

The Save Options pane contains the following options:

Generate Backup File 
Create backup files when you save the current file. If this option is active when 
you save a file:
• the tools compare the current file name with the existing list of files
• if the current file has the same name as an existing file, the tools save the 

current files with the name file name.~bc in the same directory.
Default = on

Auto Save Set the tools to schedule automatic saves for the current system. If the application 
did not shut down properly, the next time it runs, it prompts you to choose to load 
the automatically saved file.
Default = on

Auto Save Every: [ ] Minutes 
This option enables you to specify the interval for automatic saves in minutes. 
The minimum time is one minute.
Default = 5.

Clear Recent File History List

Click Clear Recent File History List to clear the recent file list that appears under the main 
File menu.

Note
 You cannot cancel this operation after you have clicked Clear Recent File History List.
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3.5.5 Canvas Appearance preferences

Figure 3-69 shows the Appearance area under the Canvas area of the AMBA Designer 
Preferences dialog box.

Figure 3-69 Canvas Appearance Preferences dialog box

Component Window Options

The Component Window Options pane contains the following options:

Icon View or List View 
Use Icon View to show all the available components in the Component Window 
in a grid.
Use List View to show the components in a list.
The two views show the icon and the text name.
Default = icon view with the icons on a grid.

Show unavailable 
Show or hide components that are part of the Component Library, but are not 
currently available.
Default = on.

3.5.6 Diagram Window preferences

Figure 3-70 on page 3-59 shows the Diagram area under the Canvas area of the AMBA 
Designer Preferences dialog box.
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Figure 3-70 Canvas Diagram Preferences dialog box

This section describes how to set the preferences for the Diagram Window.

Double Click on Objects

Double-clicking on objects can have the following effects:

Edits Parameters 
Set the double-click action, on an object that has parameters, to open the Edit 
Parameters dialog box. Otherwise, the double-click action opens the Rename 
dialog box.

Renames Set the double-click action, on an object that can be renamed, to open the Rename 
dialog box. Otherwise, the double-click action opens the Edit Parameters dialog 
box.

Grid Options

The Grid Options pane contains the following controls:

Show Grid Toggle the display to show or hide the grid.
Default = on.

Snap to Grid 
Toggle the cursor and objects to snap to the grid or move off the grid.

Reset to Default 
Click this button to reset all Grid Options to the default values.

Grid Horizontal Spacing 
Set the horizontal spacing between grid points in pixels.
Default = 10.

Grid Vertical Spacing 
Set the grid points in pixels.
Default = 10.
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Grid Point Diameter 
Set the diameter of grid points in pixels.
Default = 1.

Select Point Color... 
Select the color of grid points.
Default = Gray.

Miscellaneous

The Miscellaneous pane contains the following controls:

Draw Diagram with Color 
Force Canvas to draw the diagram only using black, gray, and white.
Default = on.

Auto arrange ports when resizing component 
Set the tools to automatically move ports if the component is made smaller. Ports 
move back to their original positions when the component is made larger.
Default = on.

Select Background Color... 
Set the background color.
Default = White.

3.5.7 Canvas IP-XACT preferences

Figure 3-71 on page 3-61 shows the IP-XACT area under the Canvas area of the AMBA 
Designer Preferences dialog box.
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Figure 3-71 Canvas IP-XACT Preferences dialog box

This section describes how to set the IP-XACT preferences.

IP-XACT Global Preference

The IP-XACT Global Preference pane contains the following controls:

Suppress IP-XACT Repository warning messages 
Select this option to force Canvas to suppress all IP-XACT Repository warning 
messages.

Caution
 Use this option with care.

IP-XACT Default Values

The IP-XACT Default Values pane contains the following entry boxes:

Vendor The default Vendor entry for the VLNV identifier of IP-XACT object 
descriptions.

Library The default Library entry for the VLNV identifier of IP-XACT object 
descriptions.
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IP-XACT Repository

The IP-XACT Repository pane contains the following entry box:

Bus Definitions Paths 
Specifies where the tool searches for the Bus Definition files. Click Edit to 
display the IP-XACT Directories dialog box and enter the directory paths. See 
Figure 3-72.

Figure 3-72 IP-XACT Directories dialog

The options available in the dialog box are:
Add This opens the Add/Edit IP-XACT Repository directory dialog box. 

You can directly type in a new directory or click Browse... to select a 
new directory entry. Click OK to close the Add/Edit IP-XACT 
Repository directory dialog box. Click Cancel to close the Add/Edit 
IP-XACT Repository directory dialog box without adding a new 
directory entry.

Edit This opens the Add/Edit IP-XACT Repository directory dialog box. 
You can select and edit an existing directory entry. Click OK to close 
the Add/Edit IP-XACT Repository directory dialog box. Click Cancel 
to close the Add/Edit IP-XACT Repository directory dialog box 
without editing a directory entry.

Remove To remove a directory entry, select an item from the list and click 
Remove. Click OK to close the IP-XACT Directories dialog box. 
Click Cancel to close the IP-XACT Directories dialog box without 
removing any directory entries.

To refresh the entries in the IP-XACT Files pane, click Refresh All BusDefs.

IP-XACT Files

The IP-XACT Files pane contains a tabbed window that lists the IP-XACT files available in the 
IP-XACT Repository. The tabs are:

All Select this tab to list all the IP-XACT file types available in the IP-XACT 
Repository.

Bus Definitions Select this tab to list all the Bus Definition files available in the IP-XACT 
Repository.

Components Select this tab to list all the Component files available in the IP-XACT 
Repository.

Designs Select this tab to list all the Design files available in the IP-XACT 
Repository.
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3.6 Label Properties dialog
To add a label to the Diagram Window you can either:

• click Label on the main toolbar

• select Insert → Add Label from the main menu

• right-click on an empty section of the Diagram Window and select Add Label from the 
context-sensitive menu.

After you select one of these options, click on the Diagram Window where you want to place 
the label. After you place the label then the Label Properties dialog box appears. Figure 3-73 
shows the Label Properties dialog box.

Figure 3-73 Label Properties dialog box

Use the dialog box to control how the label appears in the Diagram Window. The dialog box 
contains the following options:

Label Enter the text for the label in the multi-line edit box. You can use carriage returns.

Font Select the font for the entire label.

Horizontal Use the controls to set the horizontal alignment of the text in the label. You can 
choose left, center, or right alignment. The default is center.

Vertical Use the controls to set the vertical alignment of the text in the label. You can 
choose top, center, or bottom alignment. The default is center.

Rotation Use Rotation to rotate text through 90, 180, or 270 degrees.
Default = no rotation.

Colors Use the color controls to select colors for the text and background. Check the 
Transparent Background option for no background color.
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Frame Thickness 
Use the controls to adjust the frame border around the label. You can specify the 
thickness of the border with values in the range 1-99, or 0 for no border.
Default = 1.

Shadow Thickness 
Use the controls to adjust the shadow effect around the label. You can specify the 
amount of shadow with values in the range 1-99, or 0 for no shadow. The shadow 
appears below and to the right of the label.
Default = 0.

Display On Top 
Check this option to make labels appear on top of other items in the diagram.

Default Settings 
Check this option to save the current settings for all subsequent labels.
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3.7 Create IP-XACT Connection dialog
To add a connection to the Diagram Window you can either:

• click Connection on the main toolbar

• select Insert → Add Connection... from the main menu

• right-click on an empty section of the Diagram Window and select Add Connection... 
from the context-sensitive menu.

After you select one of these options then the Create IP-XACT Connection dialog box appears. 
See Figure 3-74.

Figure 3-74 Create IP-XACT Connection dialog box

To define the Connection Name you can:

• use the default selection Auto Gen Connection Name to force Canvas to generate the 
connection name for you

• deselect the Auto Gen Connection Name option and enter a name in the Connection 
Name entry box.

To select the component ports to connect:

• use the Component Instance A drop-down list to select the first component that is to be 
connected

• use the Port A drop-down list to select the port on component instance A that is to be 
connected

• use the Component Instance B drop-down list to select the second component that is to 
be connected

• use the Port B drop-down list to select the port on component instance B that is to be 
connected

• click OK to connect the two ports or click Cancel to close the Create IP-XACT 
Connection dialog box without making the connection.

Note
 You can choose to display only unconnected ports in the drop-down lists by selecting the 

Show Unconnected Ports Only option.
If the connection you have chosen is not valid, an Error box appears that provides a brief 
description of the error, and the connection is not made.
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3.8 Edit Parameters dialog
Use the Edit Parameters dialog box to view legacy component object properties and ports, and 
to modify object parameter information.

Note
 This dialog box only supports legacy devices. Use the component configurators to view and 
modify devices.

To open this dialog box, select an object from the Canvas or Hierarchy tab and select Object → 
Component Information… from the main menu. See Figure 3-75. The dialog box contains the 
following panes:

Properties This pane contains all the properties of the component object. Depending on the 
state of the object, some fields might be read-only. Reported properties include:
• Component Library name and location
• configuration file where the Component Library has been specified
• component type, version, and description
• file extension of support object files, if any
• supported debuggers, typically RealView Debugger
• component parameters
• component port list.

Ports List This pane lists the name and type of all the ports of the component object.

Parameters This pane contains all the parameters you can edit for the legacy component 
object. Double-click in the Value column to edit the parameter, and enter the new 
value. Press Enter or click in the background of the list box to accept the change.
If you edit a parameter value, the button to the right of the value field changes to 
Reset. Clicking this button resets the value to the original default value.

Figure 3-75 Example Edit Parameters dialog
ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. 3-66
ID030610 Non-Confidential



Appendix A 
Example RTL Design Flow

This appendix describes an example RTL design flow. It contains the following section:
• RTL design flow on page A-2.
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A.1 RTL design flow
You must register the AMBA component with AMBA Designer to enable AMBA Designer to 
generate, simulate, or synthesize the RTL.

The AMBA component installation package provides a UNIX script that enables you to register 
the AMBA component with AMBA Designer. See the Release note of the AMBA component 
for information about how to use the script.

Note
 The RTL generation facility is not available if:
• no AMBA Designer license feature is installed
• no corresponding IP bundle is installed.

The RTL Design Flow Manager dialog box that Figure 2-8 on page 2-9 shows controls the RTL 
design flow process. Figure A-1 shows the RTL Design Flow Manager process.

Figure A-1 RTL Design Flow Manager process

Note
 The RTL Design Flow Manager always executes the Generate RTL process before it permits the 
simulation or synthesis processes to start.

This section describes how to generate the RTL for an AMBA component by using the 4×3 
example that the AMBA Interconnect supplement to AMBA Designer describes.

Note
 To generate RTL, you must have the following development tools installed:
• Perl
• TCL.

See the AMBA Designer (ADR-301) Release Note for information about the tool versions that 
you require.

Start
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design file
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output files
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ARM DUI 0333J Copyright © 2006-2010 ARM. All rights reserved. A-2
ID030610 Non-Confidential



Example RTL Design Flow 
To generate the RTL:

1. Click Open on the main toolbar to open a file browser dialog box.

2. Load the example 4×3 AMBA Interconnect that the HPM (PL301) supplement to AMBA 
Designer describes. The file is named PL301_xxx_4x3_1.adg and is located in the default 
location:
/home/<user>/.ARM/AMBA_Designer/<x>.<y>/Designs/

Note
 You must enter /home/<user>/.ARM in the file browser dialog box because the dialog box 

does not display the .ARM directory. Where:
• <user> is the login name of the current person running AMBA Designer
• <x> is the major revision number and <y> is the minor revision number of AMBA 

Designer, for example, 3.0.

Figure A-2 shows the AMBA Interconnect that the Diagram Window displays.

Figure A-2 AMBA Interconnect

3. Right-click the axi_core_interconnect[0] component to display the context-sensitive 
menu.

4. Select AMBA Designer → PL301 RTL Design Flow Manager... from the 
context-sensitive menu. See Figure A-3 on page A-4. This opens the RTL Design Flow 
Manager dialog box.
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Example RTL Design Flow 
Figure A-3 RTL Design Flow Manager

AMBA Designer creates an XML configuration file. Figure 2-22 on page 2-20 shows the 
location of the XML configuration file.

Note
 AMBA Designer also uses the XML configuration file during batch mode operation. See Batch 
mode operation on page 2-20 for more information.

5. Click Generate RTL in the RTL Design Flow Manager dialog box. See Figure A-4.

Figure A-4 Generate RTL

AMBA Designer reads in the XML configuration file and the RTL generation process 
starts. The progress bar in the Commands pane of the RTL Design Flow Manager dialog 
box displays the progress. On completion of the RTL generation process, the progress bar 
changes color to one of the following:
Green To indicate that AMBA Designer generated the RTL successfully.
Red To indicate that AMBA Designer failed to generate the RTL.

Click Details to open the Output Window pane to display information about 
the status of the process.

The configured Verilog and synthesis are generated locally and stored in the logical and 
implementation directories. Figure A-5 on page A-5 shows the locations of these directories.
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Example RTL Design Flow 
Figure A-5 Location of Verilog and synthesis directories

In Figure A-5:

• <x> represents the major revision number and <y> represents the minor revision number of 
AMBA Designer, for example, 3.0

• <process> is either your chosen process or the process that the delivered scripts select, for 
example, tsmc65lp_adhvs.

Note
 Figure A-5 shows the directories for the PL301. For other AMBA devices, the relevant 
supplement document describes the directory structure.

The RTL generation process creates a File Reader Master (FRM) testbench based on the 
configured AMBA Interconnect. During the simulation process, the RTL Design Flow Manager 
uses the FRM testbench to verify the functionality of the configured RTL.

home/
<user>/

.ARM/
AMBA_Designer/

Designs/
PL301_xxx_4x3_1_RTL/

<top-level directory>/

implementation_<process>/
logical/

<x>.<y>/
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Appendix B 
Keyboard Shortcuts

This appendix lists the AMBA Designer Canvas keyboard shortcuts. It contains the following 
section:
• AMBA Designer Canvas shortcuts on page B-2.
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Keyboard Shortcuts 
B.1 AMBA Designer Canvas shortcuts
Table B-1 shows the keyboard shortcuts for AMBA Designer Canvas.

Table B-1 AMBA Designer Canvas shortcuts

Key Action

Ctrl + N File → New

Ctrl + O File → Open

Ctrl + S File → Save

Ctrl + F4 File → Close

Ctrl + P File → Print

Ctrl + Q File → Exit

Ctrl + Z Edit → Undo

Ctrl + Y Edit → Redo

Ctrl + X Edit → Cut

Ctrl + C Edit → Copy

Ctrl + V Edit → Paste

Ctrl + D Edit → Duplicate

Del Edit → Delete

Ctrl + A Edit → Select All

Ctrl + Shift + S Edit → Edit Mode

Ctrl + Shift + C Edit → Connect Ports Mode

Ctrl + G View → Grid

Ctrl + + View → Zoom In

Ctrl + – View → Zoom Out

Ctrl + 1 View → Set Zoom to 100%

Ctrl + F View → Zoom to Fit

Ctrl + R View → Center on Selected Object(s)

Ctrl + I View → Center Diagram

Ctrl + PgDn Window → Next Window

Ctrl + PgUp Window → Previous Window

F1 Help → AMBA Designer (ADR-301) User Guide
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Appendix C 
Migration Guide

This appendix describes how to migrate configured components created in earlier versions of 
AMBA Designer for use in version r3p0 of the product. It contains the following sections:

• Component migration on page C-2
• System migration on page C-3.
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Migration Guide 
C.1 Component migration
This section describes how to migrate components created in earlier versions of AMBA 
Designer for use in version r3p0.

C.1.1 Adding a component to the Component Library

To add a component configured in an earlier version of AMBA Designer, run the following 
script: $AD_HOME/etc/MigrateADr2toADr3.csh.

Note
 The migration script is for the Linux platform only. The Solaris platform is not supported.

After running the script, the component appears in the Component Library and you can drag and 
drop it into the Diagram Window for connecting, stitching, and saving in the new .adg file 
format.

C.1.2 Reconfiguring a component

To reconfigure or regenerate a component originally configured in an earlier version of AMBA 
Designer:

1. Load the component definition (.xml) that was created in the earlier version of AMBA 
Designer into the Configuration Window for the same component.

Note
 For the NIC-301r2 configurator, you can locate and load the component definition (.xml) 

by selecting File → Open... from the main menu of the component Configuration 
Window. For all other IP, click Browse in the File Creation Options pane of the 
Configurator Window. See Example Configurator Window on page 2-7.

2. Click OK to generate the new component configuration, and close the Configuration 
Window.

3. In the Diagram Window, right-click the generated component, and select Reconfigure 
from the context-sensitive menu.

4. Save the new component configuration, or follow the normal steps to render the 
component.
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Migration Guide 
C.2 System migration
AMBA IP-XACT components now have a one-to-one mapping with the RTL. This is not the 
case for systems that use .mxp files created in earlier versions of AMBA Designer, and you 
cannot open these directly.

To migrate a system created in an earlier version of AMBA Designer:

1. Convert the .mxp system file to an .adg file by migrating the components using the 
method that Adding a component to the Component Library on page C-2 describes.

2. Re-instantiate and reconnect the migrated components in the Canvas.
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Appendix D 
Revisions

This appendix describes the technical changes between released issues of this book.

Table D-1 Differences between issues A through F

Change Location

No revision history recorded -

Table D-2 Differences between issue F and issue G

Change Location

Removed references to SoC Designer and SoC Designer Simulator Throughout book

Removed references to cycle accurate modeling Throughout book

Removed references to Microsoft Windows Throughout book

Moved all third-party EDA tool specific content to introduction Throughout book

Removed references to Bandwidth Monitoring Components (BMCs) Throughout book

Added information on third-party tools Third-party tools on page 1-5

Added information on third-party software Third-party software on page 1-6

Removed Installation Chapter and moved information to separate book AMBA Designer (ADR-301) Installation Guide

Removed description of MemMap dialog Chapter 3 Canvas Reference

Changed description of Component Wizard Using the Components Wizard on page 2-20
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Revisions 
Changed description of command line options Table 2-1 on page 2-21

Added reference content for canvas Chapter 3 Canvas Reference

Removed What’s This from the Help menu Help menu on page 3-14

Removed IP-XACT Properties... from the Component Context menu Component context-sensitive menu on page 3-21

Removed description of System Properties dialog Chapter 3 Canvas Reference

Added reference content for keyboard shortcuts Appendix B Keyboard Shortcuts

Table D-3 Differences between issue G and issue H

Change Location Affects

Changed the description for the Help menu to match the new functionality Help menu on page 3-14 r2p3

Added bullet points stating that hierarchical IP stitching is not supported, and that you must 
specify default tie-off values in binary format and not in hexadecimal format

Limitations on page 3-46 r2p3

Table D-4 Differences between issue H and issue I

Change Location Affects

Removed all references to the Component Wizard. Use of this tool is now subject to an 
additional license agreement.

Chapter 3 Canvas Reference r3p0

Removed all references to dummy components. IP-XACT 1.4 is now supported natively. Throughout book r3p0

Removed all references to component models as these are no longer supported. Throughout book r3p0

Described all the new IP-XACT component features added to Preferences, the main and 
context-sensitive menus, the toolbar and existing and new dialog boxes.

Throughout book r3p0

Table D-5 Differences between issue I and issue J

Change Location Affects

Removed all references to generic IP stitching Throughout book r3p0

Note added, the Hierarchy Window option controls the display of the AMBA 
Configuration Window

• Window menu on page 3-13
• AMBA Configuration Window 

on page 3-26

r3p0

Updated the location of the preferences .ini file Figure 3-64 on page 3-52 r3p0

Updated the keyboard shortcuts Table B-1 on page B-2 r0p0

Table D-2 Differences between issue F and issue G (continued)

Change Location
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Glossary

This glossary describes some of the terms used in technical documents from ARM.

Advanced eXtensible Interface (AXI)
A bus protocol that supports separate address/control and data phases, unaligned data transfers 
using byte strobes, burst-based transactions with only start address issued, separate read and write 
data channels to enable low-cost DMA, ability to issue multiple outstanding addresses, out-of-order 
transaction completion, and easy addition of register stages to provide timing closure.

The AXI protocol also includes optional extensions to cover signaling for low-power operation.

AXI is targeted at high performance, high clock frequency system designs and includes a number 
of features that make it very suitable for high speed sub-micron interconnect.

Advanced High-performance Bus (AHB)
A bus protocol with a fixed pipeline between address/control and data phases. It only supports a 
subset of the functionality provided by the AMBA AXI protocol. The full AMBA AHB protocol 
specification includes a number of features that are not commonly required for master and slave IP 
developments and ARM recommends only a subset of the protocol is usually used. This subset is 
defined as the AMBA AHB-Lite protocol.

See also Advanced Microcontroller Bus Architecture and AHB-Lite.

Advanced Microcontroller Bus Architecture (AMBA)
A family of protocol specifications that describe a strategy for the interconnect. AMBA is the ARM 
open standard for on-chip buses. It is an on-chip bus specification that details a strategy for the 
interconnection and management of functional blocks that make up a System-on-Chip (SoC). It aids 
in the development of embedded processors with one or more CPUs or signal processors and 
multiple peripherals. AMBA complements a reusable design methodology by defining a common 
backbone for SoC modules.
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Glossary 
Advanced Peripheral Bus (APB)
A simpler bus protocol than AXI and AHB. It is designed for use with ancillary or 
general-purpose peripherals such as timers, interrupt controllers, UARTs, and I/O ports. 
Connection to the main system bus is through a system-to-peripheral bus bridge that helps to 
reduce system power consumption.

AHB See Advanced High-performance Bus.

AHB-Lite A subset of the full AMBA AHB protocol specification. It provides all of the basic functions 
required by the majority of AMBA AHB slave and master designs, particularly when used with 
a multi-layer AMBA interconnect. In most cases, the extra facilities provided by a full AMBA 
AHB interface are implemented more efficiently by using an AMBA AXI protocol interface.

Aligned A data item stored at an address that is divisible by the number of bytes that defines the data size 
is said to be aligned. Aligned words and halfwords have addresses that are divisible by four and 
two respectively. The terms word-aligned and halfword-aligned therefore stipulate addresses 
that are divisible by four and two respectively.

AMBA See Advanced Microcontroller Bus Architecture.

APB See Advanced Peripheral Bus.

AXI See Advanced eXtensible Interface.

AXI channel order and interfaces
The block diagram shows:
• the order in which AXI channel signals are described
• the master and slave interface conventions for AXI components.

AXI terminology The following AXI terms are general. They apply to both masters and slaves:

Active read transaction 
A transaction for which the read address has transferred, but the last read data has 
not yet transferred.

Active transfer 

A transfer for which the xVALID1 handshake has asserted, but for which 
xREADY has not yet asserted.

Active write transaction 
A transaction for which the write address or leading write data has transferred, but 
the write response has not yet transferred.

AXI 
interconnect

Write address channel (AW) 
Write data channel (W) 

Write response channel (B) 
Read address channel (AR) 

Read data channel (R) 

Write address channel (AW) 
Write data channel (W) 

Write response channel (B) 
Read address channel (AR) 

Read data channel (R) 

AXI slave 
interface

AXI master 
interface

AXI
master

AXI
slave

AXI master 
interface

AXI slave 
interface

1. The letter x in the signal name denotes an AXI channel as follows:
AW Write address channel.
W Write data channel.
B Write response channel.
AR Read address channel.
R Read data channel.
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Glossary 
Completed transfer 
A transfer for which the xVALID/xREADY handshake is complete.

Payload The non-handshake signals in a transfer.

Transaction An entire burst of transfers, comprising an address, one or more data transfers and 
a response transfer (writes only).

Transmit An initiator driving the payload and asserting the relevant xVALID signal.

Transfer A single exchange of information. That is, with one xVALID/xREADY 
handshake.

The following AXI terms are master interface attributes. To obtain optimum performance, they 
must be specified for all components with an AXI master interface:

Combined issuing capability 
The maximum number of active transactions that a master interface can generate. 
It is specified for master interfaces that use combined storage for active write and 
read transactions. If not specified then it is assumed to be equal to the sum of the 
write and read issuing capabilities.

Read ID capability 
The maximum number of different ARID values that a master interface can 
generate for all active read transactions at any one time.

Read ID width 
The number of bits in the ARID bus.

Read issuing capability 
The maximum number of active read transactions that a master interface can 
generate.

Write ID capability 
The maximum number of different AWID values that a master interface can 
generate for all active write transactions at any one time.

Write ID width 
The number of bits in the AWID and WID buses.

Write interleave capability 
The number of active write transactions for which the master interface is capable 
of transmitting data. This is counted from the earliest transaction.

Write issuing capability 
The maximum number of active write transactions that a master interface can 
generate.

The following AXI terms are slave interface attributes. To obtain optimum performance, they 
must be specified for all components with an AXI slave interface:

Combined acceptance capability 
The maximum number of active transactions that a slave interface can accept. It 
is specified for slave interfaces that use combined storage for active write and 
read transactions. If not specified then it is assumed to be equal to the sum of the 
write and read acceptance capabilities.
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Glossary 
Read acceptance capability 
The maximum number of active read transactions that a slave interface can 
accept.

Read data reordering depth 
The number of active read transactions for which a slave interface can transmit 
data. This is counted from the earliest transaction.

Write acceptance capability 
The maximum number of active write transactions that a slave interface can 
accept.

Write interleave depth 
The number of active write transactions for which the slave interface can receive 
data. This is counted from the earliest transaction.

Beat Alternative word for an individual transfer within a burst. For example, an INCR4 burst 
comprises four beats.

See also Burst.

Burst A group of transfers to consecutive addresses. Because the addresses are consecutive, there is 
no requirement to supply an address for any of the transfers after the first one. This increases 
the speed at which the group of transfers can occur. Bursts over AMBA are controlled using 
signals to indicate the length of the burst and how the addresses are incremented.

See also Beat.

Byte lane strobe A signal that is used for unaligned or mixed-endian data accesses to determine which byte lanes 
are active in a transfer. One bit of this signal corresponds to eight bits of the data bus.

Direct Memory Access (DMA)
An operation that accesses main memory directly, without the processor performing any 
accesses to the data concerned.

DMA See Direct Memory Access.

Halfword A 16-bit data item.

Unaligned A data item stored at an address that is not divisible by the number of bytes that defines the data 
size is said to be unaligned. For example, a word stored at an address that is not divisible by four.

Word A 32-bit data item.
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