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1. Introduction

We use one of the example reports that are included with Streamline. These reports provide a
quick way of exploring the features of the Streamline performance analyzer. The sample report
used in this tutorial was captured by running the XaoS example included in Arm Development
Studio (Arm DS) on a Cortex-A7 and Cortex-A15 Versatile Express board.
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2. Import the Linux example project

The sample Streamline Xao$S report was generated using the XaoS example project in Arm DS.
Therefore, to work with the report, you must import the Arm DS XaoS example project to your Arm
DS Workspace. To import the XaoS example project:

1. Open Arm DS IDE.
2. Click File > Import.

3. Inthe Import window, expand Arm Development Studio and select Examples & Programming
Libraries. Click Next.

Figure 2-1: Examples & Programming Libraries option from import window

* Import O it

Select N

Imports the Arm Development Studio examples to the current workspace

Select an import wizard:

type filter text

& General A
v = Arm Development Studio

" Examples & Programming Libraries
K3 pVision Project

& C/C++

= Git

& Install

= Remote Systems

= Run/Debug

@ < Back | Next > | Finish Cancel

4. In the Import Examples and Programming Libraries window, expand Examples > Linux
Applications and select xaos. You can also write “xaos” in the search bar to locate the example
project. Click Finish.
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Figure 2-2: xaos option from Import Examples and Programming Libraries window

* Import Examples and Programming Libraries ] X
Import Development Studio Examples and Programming Libraries @Z- 4
Y Some projects cannot be imported because they already exist in the workspace or in workspace

directory
‘ Xaos x ‘

v [m] Examples

v [m] Linux Applications
Xaos
H

Description
This example illustrates Streamline performance analysis, including annotation, using the example "Xaos”

application.

Working sets

(] Add project to working sets New...
Select...
@ < Back Next > Finish Cancel

5. The xaos example project now appears in the Project Explorer view.

What is XaoS?:

XaoS is an open-source “interactive fractal zoomer” application. In our case, it runs multi-
threaded to generate an interesting report.
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3. Import the Streamline example report

Streamline is included with Arm DS installation. Now open Streamline. You will see the following
IDE:

Figure 3-1: Streamline IDE
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Ho consoles 1o dglay at this time. T
=S ES

Now, you must import the XaoS Streamline example report. To import the example reports:
1. Click File > Import...

2. Select Import Streamline Sample Captures and click Next.
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Figure 3-2: Import Streamline Captures option.

O X
Select [ﬁ
Select an import wizard:
type filter text
e Import Capture
. Import Streamline Sample Captures
< Back Next > Finish Cancel

3. You can now select the sample Streamline captures available that you want to import. For this
tutorial, select the Linux > Arm DS Xaos Example. To import the sample capture, click Finish.
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Figure 3-3: Arm DS Xaos Example option
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Import Sample Captures
Select the sample captures to import from the list below:
v Linux
Annotations Examples
Arm DS Annotate Example
Arm DS Cache Test Example
Arm DS Xaos Example
v [v] Bare-Metal
Bare-Metal Agent Example running on Armv8 model
RTXv4 Traffic Lights Example running on Cortex-A5
Bare-Metal Agent Example running on Cortex-R5 model
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< Back Next > Finish Cancel
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Re-analyze the report

4. Re-analyze the report

The Linux - TC2 - Xaos capture is listed in the Streamline Data view. Notice that the vertical bar at
the left of the capture (in the list of captures) is yellow, meaning it must be re-analyzed.

Figure 4-1: Streamline Data view yellow bar

Streamline - Arm Development Studio Gold Edition
File Edit Streamline Window Help
% Streamline Data % Capture Control = B | % Start

ol [ Filter b JETERTIN Select Target

l *» xaos-multithreaded-VE-A15x2-ATx3

Enter target details

* Bare-Metal - AS - RTX Traffic Lights Enter the target address in the form <hostnames, <hostname=:<port>, or adb:<serial-number
* Barman - A5 - RTX Traffic Lights Or, choose an existing target
» Barman - A9 - RTXS Blinky | o Dewis |

* Barman - AArch64

* Barman - M3 - mcbstm32e
* Barman - M33 - RTX5 Blinky
* Barman - RS

Mo targets have been detected. Please refer to the gator
* Linux - Annotations

I * Linux - Arm DS Annotate Example

* Linux - Arm DS Cache Test Example

Configure Application

* RTXv4_Streamline_bare_metal_example_2
Opticnally, enter the command you wish to run:

Command: | Enter the

Working Directory:

User Name:

@ Console @ - P R

R e i EErro——

Why do | have to re-analyze the report?

Since the report was generated with a different version of Arm DS, you must re-analyze it in to
update it. In the Analyze dialog box, you can load extra program images. These images can be
useful for gaining a more comprehensive idea of system execution, or alternatively, for focusing on
one particular program. Streamline loads debug symbols if available.

To open the Analyze dialog, double-click on the Streamline capture. In the Program Images tab,
select the ELF images xaos and libpthread-2.17.so. Then click Analyze. Re-analyzing the capture
might take some time.
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Figure 4-2: Streamline Data view analyze window

Linux - TC2 - Xaos

Analyze

Choose the settings to produce a new report.

Process Extra Debug Information (when available)

Resolution mode: Normal v

Program Images| Script Search Paths

& O & Add ELF image... [ Select Separate Debug Image... % Remows
Use MName Symbols Debug Info CFI Remarks
|E b xaos v v v

|E i libpthread-2.17.s0 v 2] [Z]

Debug data in separate files

Cancel

Copyright © 2021 Arm Limited (or its affiliates). All rights reserved.
Non-Confidential

Document ID: 102590 0100 01 en

Version 1.0
Re-analyze the report

Page 13 of 20



Analyzing an example Streamline report with Arm DS Document ID: 102590_0100_01_en
Version 1.0
Exploring the example report

5. Exploring the example report

The XaoS report opens in a new tab automatically once you have re-analyzed it. It provides a
summary view of CPU performance, branch mispredictions, memory and cache accesses, along
with a sample of the frame buffer. Note that the vertical bar of the capture is now colored blue in
the Streamline Data view, meaning it is up to date.

Figure 5-1: Streamline data view blue bar
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®L3 dans aceess

o idle
O * i kernal

& Console
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T

Witieat Map [H] ~ CPU Activity = o

In the panel underneath these charts, there is a heatmap for each process and thread. Click
individual processes or threads to reconfigure the charts to reflect them. You can also see
annotations on each thread and the frame buffer, which are being passed from the source code.
These annotations are a very useful profiling tool when you are working on your own code.

Along the top of the report, there are tabs which break down the data all the way to source code
level. When using Streamline to profile your own software, look for areas where the CPU is being
pushed hard, or where the cache is being heavily used. Then, try to identify which line of code is
causing this.

| see numerous <unknown code in "x"> in the Call Paths and Functions tabs:

This issue relates to the images that you use for analysis in the first place. By default,
this capture only includes a couple of images (in this case, the images xaos and
libpthread-2.17.s0). SO, while Streamline knows that function “x” is taking up a certain
percentage of processor time, it does not know what this code is.
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6. Add the missing source code

In the Functions tab, try double-clicking on a function name such as calculate. This action takes you
to the corresponding line of source code. However, the source file is missing.

Figure 6-1: A description of the image for screen readers
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Follow the on-screen hint to Click here to locate the file. You can find the source code for the
XaoS example project in your workspace. You can locate the file in c:\Users\<User>\Development

Studio Workspace\xaos\xaos-3.5\src\engine\calculate.h.
Once you have located the file, the source code appears:

Figure 6-2: A description of the image for screen readers
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7. Example - How to analyze the Streamline
capture

In the Timeline view, you can see a timeline with information such as CPU activity, branch
mispredictions, and instructions executed. You can click the timeline to set a cross-section market
at 1.75 seconds of execution. That point in the execution time corresponds to one of the activity
peaks in the Cortex-A7 core.

In the heat map below, you can see the CPU activity for the different processes. At 1.75s, you
notice that the xaos #2750 process is in orange color, using 36.37% of the CPU Activity.

Figure 7-1: Heat map showing the xaos #2750 process using 36.37% of CPU Activity
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- en
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0 Access
. o an
Cache (Cortex-A15)
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T B YAIUI wE T UE
i bsession #2356
#1 menu-cached #2468
= rsyskegd #1369
i sch-agent #2399
* ol xaos #2750 A
A Xorg #2192

WHeat Map [HI = CPU Activity ™ 13

Go to the Call Paths view selecting the Call Paths tab. The main code is contained within the xaos
#2750 process and thread. We want to see which functions in main are using more resources. If
you click main, you can see that more than half of the samples (52.81%) in main correspond to

the function visualannotateImage. That corresponds to a 11.11% of samples in the xaos #2750
process.
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Figure 7-2: Call Paths view
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Now, select the Functions tab to see the Functions view. You can see that the function
VisualAnnotateImage appears at the top and that it is one of the functions with the highest
number of samples. Double-click the function to open the Code view for the visualannotateImage
function.

Figure 7-3: Functions view
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# cunknown code in kernel> 47,322 _ 47322 _ 23 1] - - - A

* calculate 1.462 2.79% 2999 5.72% 21 16 240 caloulate.h5 X305

+ VisualAnnotatelmage 732 1.39% 733 1.406% 1 36 424 annotate.c148 %305

& <unknown code in libge-2,17 50> 723 1.38% 123 1.38% 7 o - - -

@ mand _calc 592 1.13% 592 1.13% 10 16 804 xaos 305

# <unknown code in libpbman-1.50.0.28.2> 485 0.92% 485 0.92% 2 0 -- -

# fillline_32 246 0.47% 246 0.47% 9 4 124 zoomd.c296 HBOS

* calceolumm_32 175 0.33% 1,376 2.62% 10 44 984 zoomd.c145 ¥A0S

# caldine_32 107 0.20% 1,007 1.92% 10 44 932 zoomd.c39 A0S

& mkrealloc_table 85 0.16% as 0.16% 5 52 2,704 zoom.c45T XAOS

* moveoldpoints T9 0.15% 9 0.15% 5 40 244 zoom.c954 X305

* mand_peri 48 0.09% 48 0.09% n 16 1,236 xaos Xaos

® plt [xaos] 46 0.09% 46 0.09% 5 0 2,456 xaos XA0S

¢ _aeabi_uidivmod 39 0.07% 39 0.07% 5 0 28 waos XA0S

One of the advantages of Streamline is that you can obtain a performance analysis from a high level
and general perspective to the lowest level possible. In this example, we began detecting one of
the processes with the highest CPU activity. Then, we detected one of the functions with more
samples, within the main code that is executed in that process. Now, we can reach the lowest level
possible, which is detecting which instructions are executed more frequently.
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In the Code view, you see the code for the visualannotateImage function, which is included in
annotate.c. Select the highlighted icon in the following image to also show the assembly code:

Figure 7-4: Code view tab

v Start| M Linux - TC2 - Xaos

!Timeline‘ﬁ’ Call Paths“b Functions | w Code
.\Q@q b4l © ~ & 4} | Find

The code in line 174 (for loop) corresponds to the 49.04% of the samples in the function. If you
click the line 174, you can see the associated assembly code in green. You have been able to locate
the instructions that are constantly executed in your code. This procedure can help you detecting
bottlenecks in your code. The instruction app r2, r2, #3 corresponds to the 30.05% of the samples
in the VisualAnnotateImage function.

Figure 7-5: Highlight of the for loop on line 174 in code view

# Start| = Linux - TC2 - Xaos &
B Timeline |+ Call Paths @ Functions = Code ¥ Log

il o~ & B | Find 359 (0.68%) | @
Self: Samples (#/%) | Line Source File: C:/Users, /Development Studio Workspace/xaos/xaos-3.5/src/ui/ui-drv/gtk/annotate.c ~
178 // Copy (and invert) the Xaos fractal screen data in CAIRO_FORMAT_RGB24 (32 bit) format
171 /{ to the visual annotation bmp buffer in 24 bit format
172 for (row = bmp_height-1; row >= 8; row--) {
173 screen_row start = row * bmp width * 4;
359 4g9deax 174
93 12.7e% 175 buffer[offset++] = screen_data[screen_row_start++]; // b
138 18.85% 176 buffer[offset++] = screen_data[screen_row_start++]; // g
88 1e.93% 177 buffer[offset++] = screen_data[screen_row_start++]; // r
178
175 /{ discard unused upper (A) byte, but set to opaque for the Screen Viewer
62 B.47% 188 screen_data[screen_row_start++] = @xFF;
181 ¥
182 memepy (&buffer[offset], pad, bmp_pad_bytes);
183 offset += bmp_pad_bytes;
184 ¥
1B5
186 nNNOTﬁTE_VI!;;UAL(buffer', bmp_file_size, "Xaos"); -
Self: Samples (/%) || Address Opcode  Disassembly -~
BxPPREE974 ADD r2,r5,rd
Ox80866978 MoV ri,ne
45 65.15% BxP85697C LDRB re,[r3,%8]
1 @.14% 2x80856980 ADD rl,ri, #l
228 38.85% 2x80856984 ADD r2,r2,#3
Ox2085698E ADD r3,r3,na
48 6.56% Bx085698C STRB re,[rs,r4]
2xeas6992 ADD rd,rd,%3
92 12.57%  9x00066994 LDRB re,[r3,%-3]
46 65.28% Bx0056958 STRB re,[r2,%-2]
41 5.60% Bx085695C LDRB re,[r3,%-2]
39 5.33% Bx0056948 STRB re,[r2,%-1]
62 B.47% Bx00569A4 STRB r7,[r3,%-1]
41 5.60% EPCEELETY LDR re,[rs,%a]
97 13.25% Bx828669AC cMp ra,rl
BxPa569E0 BGT {pc}-8x34 ; Bx6697c -
P ——— L Sn Tam oana
< >
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8. Add the project path to streamline
locations

If you generate and save your own Streamline reports in a project, you must include the location
of the reports. You must indicate the path to the folders with the captures you want to analyze, so
Streamline can find the captures in your file system.

As an example, in case you created and saved reports in your Xaos project:
1. In Streamline, click Window > Preferences.
2. To add or remove locations where Streamline analysis data can be found, select Data Locations.

3. Click New and select the Streamline folder with captures within the xaos project folder in your
workspace. Then click Apply and close.

4. Your captures are now listed in the Streamline Data view.
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